使い方(TextClipper)

使い方

はじめに

初級編

  実行方法
  梱包ファイルを解凍してTEXTCLIP.EXEをダブルクリック！

  カードの登録と画面
  フォルダを指定してエディタ部分に書き込むだけ。
  カード中の文章で、検索と置換ができます。

  一発フロッピー書き出し
  自分で書いたテキストを人に渡す時、フロッピーに落とすのも結構面倒なものです。
  ここに登録してあるテキストならそのカードを表示させて「フロッピーボタン」を押すだけでそのカードのテキストをフロッピーに書き出すことが可能です。
  初心者の方のエディタとしても利用できるでしょう。
  表モードのものはCSVファイルとして書き出します。

  一発ペースト　超一発ペースト
  コンパクトなボタンウインドウを使って、普段使っているエディタなど他のソフトに、テキストを簡単に張り付けられます。ボタンウインドウを使わずに、キー操作でもできます。
  クリップボードの履歴もペーストできます。

  一発登録
  ここを登録したいというところをマウスで選択してボタン一発で登録されます。

  ブラウザ(インターネット・エクスプローラ)から一発登録でカードに追加すると、テキスト・データだけでなく、画像や表も同時に取り込むことができます。
(バージョン7.8 ～で追加された機能です。
スタイルシートCSSで指定した、色やフォントは、再現できません。)

  カードの削除

  ツリーリストでの操作

上級編

  カード検索
  指定した文字を含むカードを検索します。

  置換機能
  定型文書で氏名など一部を変えたいときに便利です。
  プログラミングにも使えます。

  カード読み込み

  環境設定

  カード取り込み 書き出し
  他のコンピュータと TextClipper(以下TCと書きます) のデータを授受したり、他のソフトとデータの受け渡しができます。

  バックアップ
  一発で２種類のバックアップが可能です。

  その他

超上級編

  データファイル切り替え
  データが多くなってきた場合、複数のデータファイルに分けて使えます。

  クリップツール
  クリップボードでテキストの加工を行います。

  クリップツールの作成
  ソース付きなので自分で作って下さい。

トラブル解消法

  FAQのページも参照下さい。
  1. 　ツリーでタイトルをクリックすると、小窓(簡易エディタ)が開いてしまう
      タイトルをマウス左でシングルクリックして下さい。左ダブルクリックだと、簡易エディタが開きます。

  2. 　TCの画面が表示されない
    1. 　突然TCの画面がウインドウから居なくなった(表示されない)ときは、タスクトレイ(タスクバーの通知領域)のアイコンをマウス「左」シングルクリックして現れる、「メニュー(M)」の下の「位置リセット(E)」を実行してみて下さい。
      緑で囲んだ部分が、タスクトレイアイコン

    2. 　上記でもダメで、ボタン・ウインドウ ボタン・ウインドウ だけがパソコンの画面に表示されている場合は、次の方法で、レジストリの情報をリセットします。
      ①SHIFTキーを押しながらTextClipper.exeをクリックして立ち上げる。
      ②「環境設定の情報をクリアしますか？」→　はい
      そして、再度TextClipperを起動します。
      この方法では、環境設定に登録した内容の一部が消えるため、先に a. の方法を試して下さい。

    3. 　テキスト部の背景色を黒にしているとき、リッチテキストを取り込むと、TCのテキスト画面が真っ黒で文字が見えないことが有ります。こんなときは、TCを再起動して下さい。

  3. 　ボタン・ウインドウ ボタン・ウインドウ が、他のソフトのウインドウの裏に隠れて見えなくなる
      「ボタンウィンドウをタイトルバーにのせる」設定にしていないとき、Windowsのバージョンや、他のソフトとの相性で、ボタンウインドウが隠れる場合が有ります。
      この場合は、「環境設定(O)」→「環境設定(O)」→「起動時タブ」で、「ボタンウィンドウをタイトルバーにのせる」にチェックを入れます。

  4. 　他に、Windows のクリップボードのデータを取得するソフト(例えば電子辞書検索ソフト DDwin のクリップボード経由自動検索など)が動いていると、一発登録やクリップツールが働かないことが有ります。
      クリップボードのデータを intercept されないような状態にして使って下さい。

  5. 　ツリー部の幅を変えたいときに、テキスト部との境目にマウスカーソルを持っていっても、ポインターの形が、←||→ に変わらない
      パソコンを再起動して、TCだけを立ち上げて、何も入力していていない状態で試して下さい。他のソフトが動いていたりすると、←||→ が出ない場合が有ります。

  旧バージョンからのコンバート
  次回からのために読んでおいて下さい。

おたより

E-Mail 　:takaki@try-net.or.jp

HomePage :「まなつのみかん」
          http://takaki.la.coocan.jp/
      〒859-62
      北松浦郡鹿町町下歌ヶ浦免957-7
      吉村隆樹
[Keyword] 使い方

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


はじめに(TextClipper)

はじめに

TextClipper？

  日本のインターネット人口は、2004年末では6,700万人で、世帯浸透率は78％になり、インターネットは情報検索のメディアとして中心的な存在になっています。
  ところが、そこで得た情報を管理している人は意外に少ないようです。原因は何でしょうか。情報を管理するという意識が無いこと？　それもあるでしょう。管理するほど有益な情報とは思えないから？　そうかもしれません。しかしそれ以上に、テキスト情報をどうやって管理すればいいかわからないことが、大きな原因ではないでしょうか。

  TextClipperは、世にあふれんばかりのテキスト(文章)を管理することができるソフトウェアです。
  テキストをカード単位で管理し、カードはWindowsのファイルと同様にツリー構造で管理するため、Windowsユーザーには理解しやすいテキスト管理を実現しています。

  また情報を管理する場合、その情報を入力する手間はバカにできません。特にテキストの場合は、その傾向が顕著です。そこでTextClipperでは、テキストを簡単に登録するための「一発登録機能」を用意して、入力の手間を最小限に押さえています。
  また、せっかく管理しているテキストを再利用するのも面倒なこともありますが、この点もTextClipperは見逃しません。「一発ペースト機能」で、管理しているテキストをワープロなどで簡単に利用できます。
  そして、管理しているテキストを最大限利用するための機能として、差込印刷のような「置換機能(テンプレート機能)」や、 テキストを加工して利用するための「クリップツール」が用意されています。

  さらに、テキストファイルと関連付けて、画像ファイルやExcelなどの、ファイルの管理もできます。

  このようにTextClipperは、汎用的なテキストを管理/利用するためのソフトウェアです。管理するテキストの内容はあなたの発想一つ。いろんな場面で利用できると思います。
  →参考：日記の事例

TextClipperの特長

コンパクトなボタンウインドウによる操作
一発登録機能
一発ペースト機能
強力な検索機能
カードを、タイトル or 登録日 or 更新日で、自動ソート
プレビュー付き印刷機能
URLやファイルへのリンク(画像ファイルやExcelのファイル管理もできる)
クリップツール
データベースのマージ(シンクロ)
階層付きテキスト出力
置換機能
[Keyword] はじめに

Copyright © 1999-2007 YAZAKI Makoto. All rights reserved.


はじめに - このマニュアルについて(TextClipper)

このマニュアルについて

  このマニュアルは、TextClipperのHELPファイルを元に作成されていますが、TextClipper作者の吉村隆樹さんが書かれたものではありません。よってTextClipperの動作と、このマニュアルの記述に相違がある場合は、必ずこのマニュアルの記述ミスです。きこり工房 渡辺までお問い合わせください。
  なお公式の文書はTextClipper同梱のtextclip.hlpです。旧バージョンからの移行方法や、TextClipperの変更履歴、吉村隆樹さんからのメッセージ等は、そちらをご覧ください。

  このマニュアルは、これを読む人のご意見を取り入れながら、できるだけ更新したいと思っています。ですから「パソコンソフトのマニュアルってわかりづらいよねー。もっとわかりやすく書いて欲しいよねー。」などと感じたときは、どうすればあなたにとって使いやすくなるのか。どんな情報をあなたが必要としているのかを、きこり工房サポートセンター 渡辺までお知らせください。

  TextClipperと、このマニュアルが、皆さんのお役に立ちますように。

  きこり工房サポートセンター
makoto-y@sam.hi-ho.ne.jp
http://www.sam.hi-ho.ne.jp/makoto-y/

  きこり工房(矢崎 誠さん)のマニュアル・データを引き継いで、1999年6月以降のTCの改善点その他については、渡辺真 が、追記・編集しています。
makoto_watanabe@hi-ho.ne.jp

thanks:
  Miyaさん

マニュアル左上のツールボタンの説明

非表示・表示：目次や検索の表示を切り替えます。
同期：意味不明。　(^^ゞ
戻る：リンクでジャンプしたときなど、元の画面に戻りたいときに押します。
進む：「戻る」で戻ったとき、以前の画面に進むときに押します。
ホーム：マニュアルのトップ(使い方の部分)に戻ります。
フォント：マニュアルを表示するフォントの大きさを5段階調節できます。
目次：下位の目次を開くときは、「＋」をマウスで左シングルクリックするか、アイコンかタイトル部分を左ダブルクリックすると、明細を表示します。
検索：マニュアルの文中の言葉で全文検索できます。便利です。
  検索結果は、「タイトル」と書かれた部分をクリックすると、マニュアルのページのタイトルで並び替えできます。
お気に入り：もし頻繁に参照するページが有れば、登録できます。

マニュアルの表記について

［］で括ってある単語
  メニューやボタンなど、画面に表示される単語や、キーボードです。例えば［ファイル］とあれば、ファイルメニューまたはファイルと書かれたボタンです。
  メニューの項目は、「」でくくる場合もあります。
[Keyword] マニュアルについて
マニュアルの表記方法

Copyright © 2004-2007 WATANABE Makoto. All rights reserved.


このマニュアルについて - きこり工房について(TextClipper)

きこり工房について

きこり工房は、オンラインヘルプを作っています。フリーソフトウェアのマニュアルや、シェアウェアのオンラインヘルプを作ります。詳しくは、きこり工房サポートセンターまでお尋ねください。

また、きこり工房では、あなたの意見を取り入れながら、頻繁に更新されます。「パソコンソフトのマニュアルってわかりづらいよねー。もっとわかりやすく書いて欲しいよねー。」とあきらめる前に、どうすればあなたにとって使いやすくなるのか。どんな情報をあなたが必要としているのかを、きこり工房サポートセンターまでお知らせください。

連絡先：
きこり工房サポートセンター
makoto-y@sam.hi-ho.ne.jp
http://www.sam.hi-ho.ne.jp/makoto-y/
[Keyword] きこり工房サポートセンター
サポートセンター

Copyright © 1999-2007 YAZAKI Makoto. All rights reserved.


はじめに - TextClipperのバージョンアップについて

TextClipperのバージョンアップについて

マイナーバージョンアップの手順

バージョンが、7.5x→7.6xのように若干変わったときは、マイナーバージョンアップと呼びます。
マイナーバージョンアップのときは、カードを移行する準備をする必要がありません。
TextClipperのプログラムを登録してあるフォルダに、新しいバージョンのTextClipperの圧縮ファイルを一式、日付の新しいものを上書き解凍するだけです。

メジャーバージョンアップの手順

  バージョンが、7.xx→8.xxのように大きく変わったときは、メジャーバージョンアップと呼びます。
  メジャーバージョンアップのときは、データの保存形式が変わることがあります。次の手順にしたがって、より新しいバージョンのTextClipperをインストールする前に、いま使っている（古い）バージョンのTextClipperからカードを移行する準備をしてください。

手順

  1. 「完全バックアップ」を使って、旧バージョンのカードを書き出す。

  2. 新しいバージョンのTextClipperをインストールする。

  3. 「他TextClipper取り込み」を使って、旧バージョンのカードを取り込む。

関連項目

他TextClipper用書き出し
他TextClipper取り込み
[Keyword] バージョンアップ
TextClipperのバージョンアップについて
メジャーバージョンアップ
マイナーバージョンアップ


はじめに - 実行方法(TextClipper)

実行方法

インストール

  梱包ファイル(textcpxx.lzh)を解凍します。このとき、解凍されたファイルは全て同じフォルダに置いてください。これでインストール終了です。
  TCはプログラムを解凍したフォルダに、デフォルトのデータファイルを作成します。このため、例えば、Dドライブの直下にTC用のフォルダを作るなど、アクセスしやすい場所を指定することを推奨します。

梱包されているファイルは
    textclip.exe　textcpdl.dll　clipsnd.wav　textclip.hlp
    textcpbt.exe　txtcpbd.cta　Textclip.chm
    sample.dat
    vcsrc.lzh　cbsrc.lzh
の10こです。
各ファイルの意味は次の通りです、

Textclip.exe　プログラム本体
Textcpdl.dll　実行時に必要なdllファイル

Clipsnd.wav　ホッチキスの音
Textclip.hlp　ヘルプファイル
Textcpbt.exe　ボタンウィンドウのプログラム（単体では実行できません）
Textcpbd.cta　標準のクリップツール
Textclip.chm　きこりヘルプ（まことさん作）
sample.dat　サンプルデータ 最初の起動時に自動で取り込まれます。
vcsrc.lzh　cbsrc.lzh　クリップツールのサンプル

データファイルは
TEXTCP7.DAT　属性部のデータ
TEXTCP7.IX0　属性部のインデックス
TEXTCP7.IX1　属性部のインデックス
TEXTCP7.TX 　テキスト部のデータ
TEXTCP7.ITX　テキスト部のINDEX

TEXTCP7.TRE　ツリー構造情報
TEXTCP7.HDT　置換処理の履歴データ
TEXTCP7.HID　置換処理の履歴のインデックス

textclip.ini 個人別の環境設定ファイル
です。これらは絶対に消したり、開いて編集したりしないようにして下さい。

UNLHA32.DLLファイルが必要です

  TextClipperを実行するには、上記とは別に、MICCO氏作の「UNLHA32.DLL」が必要です。
  UNLHA32.DLLは、次のURLからダウンロードしてください。
統合アーカイバ・プロジェクト　URL:http://www.csdinc.co.jp/archiver/

  「プログラム開始エラー」と表示されたときは、UNLHA32.DLLファイルがインストールされていないのです。

* UNLHA32.DLLのインストール方法は、付属のドキュメントをご覧ください。

TextClip.exeを実行

  インストールができたら、後は TextClip.exe を実行するだけです。
        TextClip データ１
のようにデータ名称を指定するとそのデーターベースが開けます。ショートカットでご利用下さい。

  データファイルは自動的に、TextClip.exeのあるディレクトリに作られます。
  このソフトには常駐させておくことで威力を発揮する機能がありますのでスタートアップに登録しておかれるといいと思います。

その他のファイル

  vcsrc.lzhとcbsrc.lzhはＣでwindowsのプログラミングの経験者の方のみ解凍してください。
  詳しくはクリップツールの作成をお読み下さい。

動作環境

  Win95 Win98 WinNT Win2000 WinXP
  ＬＡＮなどで同時に複数の環境から同じファイルを参照しないようにして下さい。
データが壊れる可能性があります。

アンインストール

  インストール時に作成したフォルダごと、削除してください。
  データファイルを、プログラムを解凍したフォルダと別の所に作っている場合は、このフォルダも削除します。

  TCはデータファイルのパスを、レジストリに書いています。
HKEY_CURRENT_USER
  Software
    textclip
レジストリの編集に自信があり、気になる人以外は、そのままで、削除する必要はありません。

[Keyword] TextClipperを実行するときの注意
UNLHA32.DLLファイルが必要です
プログラム開始エラー


基本的な機能(TextClipper)

基本的な機能

カード
一発登録機能
一発ペースト機能
クリップツール
その他
[Keyword] 基本的な機能


基本的な機能 - カード(TextClipper)

カード

  TextClipperでは、テキストをカード単位で管理します。また、カードはWindowsのファイルと同様に、フォルダを使ったツリー構造で管理します。
  カードの内容は、右側のテキスト部で修正することができます。フォルダやカードは、左側のツリー部で管理することができます。

  カードはフォルダに登録するため、フォルダが無いとカードを作れません。
  フォルダがないときは、ツリー部分で、まずフォルダを作って下さい。
Rootというのは特別なフォルダで、その中(下)に、新規のフォルダを作る必要があります。
  フォルダを作るときは、新規フォルダを押します。

  カードを新規に登録するときは、新規追加ボタン [image] を押します。
  また左にあるツリーリストのフォルダーにカーソルを合わせてもいいです。
  右のタイトルの下に「新規データ」と出ていたらそれが新規のカードです。
  すると、何も入力されていないカードになり、タイトル、テキストを入力します。タイトルは必ずしも入力する必要はありません。
  右側にある「ペースト」というチェックボタンはここをオンにしておくと、一発ペーストができます。

  保存操作はする必要はありません。
  入力されたデータは別のテキストに移ったり、置換処理をしたりするときに自動的に保存されます。
  どうしても不安な方や編集途中に離れるときは右上の登録ボタンを押して下さい。

  追加したデータはツリーリストのカーソルのあるフォルダに登録されます。

********************************************
  カードのアイコンのついたボタンを押すとツリー部で表示されるアイコンを変えられます。
  マウスが苦手な方は[Shift]キーを押しながら[F7]キーでもできます。

表形式(表モード)

  テキスト部の［表］チェックボックスにチェックマークをつけると、カードが表形式(表モード)で表示されます。メールアドレス一覧など、テキストを表形式(表モード)で管理したほうがわかりやすくなるときに便利です。

  表モードで2列のものは、一発ペーストするようにしておくと、この行がそれぞれ一発ペーストのデータとして認識されます。

  表モードのテキストは、印刷時にも表形式のまま印刷できます。

  タブ区切りのテキストは表モードで編集できるようになっています。
  カンマ区切りにものはタブ区切りに変換して下さい。変換の方法は全選択をしてクリップツールの「CSV－>TAB」を実行するだけです。

  表モードにするには、画面右にある「表」というチェックボックスをチェックします。
  すると上の画面のようになり、表計算風に編集できます。計算式は使えません。

   表の上で右クリック、あるいはESCキーを押すとポップアップメニューが出て、挿入や削除が行えます。

  削除機能は範囲選択をしてから実行するとその範囲が削除の対象になります。
  念のため、一度おためし下さい。

  とくに切り取りはちょっと特殊で、行全部を選択すると削除も行います。
  その後行挿入ペーストを実行すると移動ができます。

そのほかの機能
  SHIFTを押しながらENTERキーで行挿入。
  ctrlを押しながら左右の矢印キーで列幅変更。

  ctrlを押しながら上下の矢印キーで行データを移動。★マスターすると便利です。
これは便利 　エクセルやワードの表などは、タブ区切りデータなので、この表をTCに一発登録したり copy & paste したものは、表モードで表示できます。

  TCは、カード毎にフォントを変えることができます。Excelからコピーした表で、行方向の文字数が多い場合は、フォントサイズを少し小さくすると、見やすくなります。
  表モードのままでは、マウス右クリックのメニューに「このカードのフォントを変える」が表示されないので、いったん表モードのチェックを外します。
  そしてフォントサイズを変更した後、再度、表モードのチェックを入れます。

気をつけよう 　TCは、[Tab]キーで、テキスト部やツリー部にフォーカスを移したり、ボタンにフォーカスを移したりすることができます。[Tab]キーを押したときの動作は、「環境設定」の「その他」で設定できます。
  テキスト部で[Tab]キーでタブを入力できるようにするには、ここにチェックをつけます。
  「テキスト部でタブキーでタブを入力できるようにする」のチェックを外した場合は、テキスト部でタブを入力するときは、CTRL + I(アイ)を押します。

関連項目

テキスト部
ツリー部
[Keyword] 基本的な機能
カード
表形式(表モード)

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


基本的な機能 - 一発登録機能(TextClipper)

一発登録機能

  一発登録機能は、デフォルトフォルダに、カードを連続して登録する機能です。
  通信ログやプログラムを見ていて「この部分はとっておきたい！」と思ったときに、すばやくカードに登録できて便利です。

例）インターネットエクスプローラーから一発登録する手順

他のソフトでも大抵同じように一発登録ができます。
  1. 登録したいテキストを選ぶ。
    まず、下のように登録したい部分を選択（反転表示）します。

  2. ボタンウィンドウの一発登録フォルダボタン [image] をマウス左で押す。

      登録先のフォルダ一覧が表示されるので、登録先と登録方法を指定します。
      うまくフォルダ一覧が表示されないときは、再度、同じアイコンをマウスで左クリックします。

      一発登録ボタンアイコン [image] をマウス左クリックした場合は、TCデータファイルのデフォルトフォルダに、手順1で選んだテキスト（例では、「Ｑ７...(中略)...ました。」）が登録されます。
チョットひとこと 一発登録ボタンを押すかわりに、次のいずれかの操作でも一発登録ができます。
  • タスクトレイ(タスクバーの通知領域)のTextClipperアイコンを右クリックする。
    （環境設定その他タブ「タスクトレイアイコンをシングル右クリックでフォルダ指定」をチェックしてある場合は、右ダブルクリック。）
  • 一発登録キーを押す。
チョットひとこと 　ブラウザから一発登録するとき、選択したテキスト以外に URL などの「入手先情報」も合わせて取り込むことができます。
  取り込む項目は、一発登録時のテキストへの保存情報で指定します。
気をつけよう 　カードの登録が成功したときは、ホッチキスで綴じた時の音がします。既存のカードに追加した場合は、 [image] が表示されます。
  登録に失敗したときは、×印が表示されます。
  登録に失敗した場合は、一度、CTRL+C（手動でコピー）してやるとうまくいくケースがあります。
  ウインドウを一度他に切り替えて戻すとうまくいく場合もあります。
  一発登録キーでおこなうと確実にできます。

  何度やってもうまくいかないときは、相手ソフトウェアとTextClipperとの相性が悪い可能性があります。相性の問題は、特殊な環境設定を行うことで解決できるかもしれません。
  環境設定ダイアログのコピータブ
  環境設定ダイアログのカットタブ
[Keyword] 基本的な機能
一発登録機能

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


基本的な機能 - 一発ペースト機能(TextClipper)

一発ペースト機能

  一発ペースト機能は、登録されているカードを利用するときに使う機能です。デフォルトフォルダからカードを選んで、メモ帳などの他のソフトに貼り付けることができます。

例）メモ帳に貼り付ける

パソコンで入力しているときに、例えば、メモ帳で文章を書いているときに
  1. ボタンウィンドウの一発ペーストボタン [image] をマウス左で押す。
    TextClipperに登録されているフォルダの一覧が表示されます。

  2. フォルダの一覧から、貼り付けたいカードを選ぶ。
    選んだカードが、入力しているソフト(例えばメモ帳)のカーソルの部分に貼り付けられます。
チョットひとこと 　カードの設定で、一発ペースト機能でカードを貼り付ける候補の対象から外すことができます。
  カードを一発ペーストの対象から外すには、該当のカードを表示してテキスト部の［ペースト］チェックボックスのチェックマークを外します。すると、そのカードは一発ペースト機能で利用できないカードになります。
（デフォルトでは全てのカードが一発ペーストの対象になっています。）
チョットひとこと 　一発ペーストのカードを選択するときに、[Shift]キーを押しながらやると、クリップツールが選べます。
  例えば、引用マークを付けて貼りこむことができます。
チョットひとこと 　一発ペーストのショートカットを設定しておくと、キー操作だけでできます。ショートカットの設定は、環境設定のキー割り当てでします。
  一発ペーストより素早くペーストできる超一発ペーストもあります。
チョットひとこと 　一発ペーストのときに、選んだカードが置換文字列を含んでいると、置換処理が行われます。

一発Window 　一発ペーストでカードを選ぶときに、右クリックで選ぶか、選ぶ前にスペースキーを押しておくと、そのカードはペーストされないで編集可能な簡易エディタの画面で開くことができます。
  作業中にTextClipperに登録してあるメモを見るとき、わざわざTextClipperのメインウィンドウを開くまでもなく、簡単に参照できます。開いた時点でのこのwindowは常に一番上に来るようになっていますので、これを見ながら他のプログラムを操作できて便利です。
  また、この簡易エディタwindowで、編集、登録もできます。
  環境設定のその他で、TC本体で開くようにもできます。

気をつけよう 　カードの貼り付けに失敗した場合は、相手ソフトウェアとTextClipperとの相性が悪い可能性があります。相性の問題は、特殊な環境設定を行うことで解決できるかもしれません。
  環境設定ダイアログのペーストタブ

表モードの一発ペースト

  表モードで２列のものには特別な機能があります。
  表モードの例のように２列の表でしかも一発ペーストするようにしておくと、この行がそれぞれ一発ペーストのデータとして認識されます。
１列目がタイトルになり、２列目がペーストするデータになって一発ペーストができます。
  以下がそれを一発ペーストしようとしたときの例です。

  この機能を使うと、メールアドレスやfax番号、関数など１行だけのデータを１つのカードでまとめて管理できるようになります。


基本的な機能 - 一発ペースト機能 - 置換機能(TextClipper)

置換機能

置換機能は、他のソフトウェアでは、テンプレート機能、スケルトン機能と呼ばれることがあります。

カードの一部分だけを変えて、一発ペーストすることができます。
置換機能を利用するためには、変えたい部分に、置換文字列（$_Name_のように、$_と_で囲まれた文字列のこと）を入力したカードを作ります。

例）簡単な手紙

置換文字列を含む次のようなカードを、一発ペーストしようとすると、置換ダイアログが表示されます。

$_Name_様
このたびはTextClipperをダウンロードしていただき、ありがとうございます。
本プログラムはテキストのデータベースです。
（略）
本プログラムはいろんな場面で応用できると思います。
平成$_WAYEAR_年$_MONTH_月$_DAY_日

定義済みの置換文字列

置換機能では、次の8個の置換文字列がすでに定義されています。
置換文字列 | 置換後の文字列
$_WAYEAR_ | 和暦
$_YEAR_ | 西暦
$_MONTH_ | 月
$_DAY_ | 日
$_HOUR_ | 時
$_MINUTE_ | 分
$_SECOND_ | 秒
$_SELECTED_ | 一発ペーストするときに選択されている文字列

例えば、今日が99/5/31だとすると、
「$_YEAR_/$_MONTH_/$_DAY_」は、1999/05/31という文字列に、
「平成$_WAYEAR_年$_MONTH_月$_DAY_日」は、平成11年05月31日という文字列に、置き換えられます。

また、$_SELECTED_は、次のようなカードを作って使います。
「<FONT COLOR="#0000FF">$_SELECTED_</FONT>」
エディタで「赤くする文字列」と文字を選択して、このカードを一発ペーストすれば、「<FONT COLOR="#0000FF">赤くする文字列</FONT>」と、選択した「赤くする文字列」をFONTタグで囲まれます。
[Keyword] 基本的な機能
一発ペースト機能
置換機能

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


基本的な機能 - クリップツール(TextClipper)

クリップツール

  クリップツールを使うと、クリップボードを利用してテキストを加工・変換・整形することができます。
チョットひとこと 　クリップツールは、TC上だけではなく、他のソフトを使っているときにも有効です。
  「全角英数記号を半角に」とか、「半角カタカナを全角に」とか、使う機会が有るかも知れません。

  C言語のコンパイラがあれば、クリップツールを作ることができます。

クリップツールを利用するには

  加工したい文字列を、選択状態(反転)にします。
(対象の文字列は、複数行でもかまいません。全テキストを対象としたいときは、[Ctrl]+[A](全選択)が便利です。)

そして、以下のいずれかの操作をします。
  • ボタンウィンドウのクリップツールボタン [image] をマウス左で押す。
  • クリップツールキーを押す。
  • テキスト部ポップアップ(コンテキスト)メニューから［クリップツール］を選ぶ。

  ここで、使いたい機能をマウス左クリックで指定します。

  標準として添付されているクリップツールの解説を参照下さい。

  標準として添付されているクリップツール以外にも、ダウンロードのページ
http://hp.vector.co.jp/authors/VA001032/textclip.html
で、ユーザーの皆さんが作成したクリップツールをダウンロードできます。

  例えば、ホームページから一発登録して取り込んだテキストは、「空白」や「改行」がたくさん入っていることがあります。
  こんなときは、該当カードのテキストを全選択して、「こあら」さんのクリップツール「行末空白文字削除」をした上で、「連続した空行を１行に」で整形すると、冗長な空白が無くなり、格段に見やすくなります。
[Keyword] 基本的な機能
クリップツール

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


クリップツール 標準のクリップツール(TextClipper)

標準のクリップツール

引用マーク

選択したテキストに引用マーク（>）をつけてコピーします。

引用マークをつけた結果は、貼り付けて確認できます。
(例)
    こんにちは。
    今日はいい天気ですね。
上のテキストを選択して、［引用マーク］を選び、クリップボードから貼り付けた結果は、次のようになります。

    >こんにちは。
    >今日はいい天気ですね。

引用マーク（78byte）

引用マークと同じ操作です。引用マークと異なり、78byte（全角で36文字）周辺で改行を入れながら引用符をつけます。
引用コピー（78byte）の結果は、貼り付けて確認できます。

改行をとる

選択したテキストから改行を取り除きます。結果がすぐに反映されます。
(例)
    こんにちは。
    今日はいい天気ですね。
上のテキストを選択して［改行を取る］を選ぶと、次のようになります。

    こんにちは。今日はいい天気ですね。

大文字に変換／小文字に変換

選択したテキストに含まれるアルファベットを、大文字（小文字）に変換します。結果がすぐに反映されます。
(例)
    こんにちは。Hello。Ｈｅｌｌｏ。
上のテキストを選択して、［大文字に変換］を選ぶと、次のようになります。

    こんにちは。HELLO。ＨＥＬＬＯ。
上のテキストを選択して、［小文字に変換］を選ぶと、次のようになります。

    こんにちは。hello。ｈｅｌｌｏ

インデント４つ右へ／インデント４つ左へ

選択したテキストの頭にスペースを４つ挿入したり、頭からスペースを４つ削除します。結果がすぐに反映されます。

()で囲む

選択したテキストを()で囲みます。結果がすぐに反映されます。
(例)
    ほげほげふー
「ほげほげ」を選択して、［()で囲む］を選ぶと、次のようになります。

    (ほげほげ)ふー

代入逆転

代入の方向が変わります。例を見てください。［代入逆転］の結果は、貼り付けて確認できます。

(例)
    OptionFm->RunIcon | = | RunIcon;
OptionFm->AutoMove->Checked | = | MapData->AutoMove;
OptionFm->BackClipBoard->Checked | = | HukkiClipBoard;
OptionFm->UseButton->Checked | = | UseButton;
OptionFm->FileName->Text | = | BackupFile;
OptionFm->NoHukkiClass->Text | = | NoHukkiClass;
OptionFm->ClassStr | = | ClassStr;
上のテキストをクリップボードにコピーして、［代入の逆転］を選び、クリップボードから貼り付けた結果は次のようになります。
=の左右が入れ替わっていることを確認してください。

    RunIcon | = | OptionFm->RunIcon;
MapData->AutoMove | = | OptionFm->AutoMove->Checked;
HukkiClipBoard | = | OptionFm->BackClipBoard->Checked;
UseButton | = | OptionFm->UseButton->Checked;
BackupFile | = | OptionFm->FileName->Text;
NoHukkiClass | = | OptionFm->NoHukkiClass->Text;
ClassStr | = | OptionFm->ClassStr;

日時挿入

現在の日付及び時刻を貼り付けます。
「98/02/16 16:40」こんな感じです。

TAB－＞CSV

タブ区切りのテキストを、カンマ区切りのテキストにします。結果がすぐに反映されます。
(例)
    ほげほげ（タブ文字）ふー
上のテキストを選択して、［TAB－＞CSV］を選ぶと、次のようになります。

    ほげほげ,ふー

CSV－＞TAB

カンマ区切りのテキストを、タブ区切りのテキストにします。結果がすぐに反映されます。
(例)
    ほげほげ,ふー
上のテキストを選択して、［CSV－＞TAB］を選ぶと、次のようになります。

    ほげほげ（タブ文字）ふー

TAB区切りをHTMLに

タブ区切りのテキストを、HTMLのTABLEタグを使ったテキストにします。［TAB区切りをHTMLに］の結果は貼り付けて確認できます。
(例)
    ほげほげ（タブ文字）ふー
上のテキストを選択して、［TAB区切りをHTMLに］を選ぶと、次のようになります。

    <TABLE>
    <TR><TD>ほげほげ</TD><TD>ふー</TD></TR>
    </TABLE>
[Keyword] 基本的な機能
クリップツール
標準のクリップツール

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


クリップツール クリップツールを作る(TextClipper)

クリップツールを作る

  クリップツールは目的にあったものがあると非常に便利ですが、目的は人によって千差万別。作者一人で対応しきれるものではありません。クリップツールは知識のある人なら、簡単に必要なものを作って配布できます。
  詳しくは、ソースプログラムをご覧ください。

クリップツールの機能

クリップツールには、おおきくわけて次の４種類の機能があります。
  • クリップボードの内容を変える。
  • 選択されている文字列を、クリップボードにコピーして加工する。
  • クリップボードの内容を加工して、貼り付ける。
  • 選択されている文字列を、加工したものに置き換える。

Visual C++用ソースプログラム

ソースプログラムは、vcsrc.lzhに入っています。
この中に含まれているtextcpbd.cに、あなたに必要な処理を書き加えて、コンパイルします。

Borland C++ Builder用ソースプログラム

ソースプログラムは、cbsrc.lzhに入っています。
この中に含まれているuser.cに、あなたに必要な処理を書き加えて、コンパイルします。
[Keyword] 基本的な機能
クリップツール
クリップツールを作る

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


特殊な機能(TextClipper)

特殊な機能

クラス名の取得
[Keyword] 特殊な機能


基本的な機能 - 一発Window(TextClipper)

一発Window

  一発ペーストでカードを選ぶときに、右クリックで選ぶか、選ぶ前にスペースキーを押しておくと、そのカードはペーストされないで編集可能なwindowで開くことができます。

  作業中にTextClipperに登録してあるメモを見るとき、わざわざTextClipperのメインウィンドウを開くまでもなく、簡単に参照できるように作りました。
  開いた時点でのこのwindowは常に一番上に来るようになっていますので、これを見ながら他のプログラムを操作できて便利かと思います。
  また、このwindowでの編集、登録も可能です。

  「環境設定」の「その他」で本体で開くようにも出来ます。


基本的な機能 - その他(TextClipper)

その他

このソフトには書くほどではないのですが、小さな工夫があります。
それらを、ちょっと列挙しておきます。

  1. メニューの環境設定でTEXT部の背景色を設定できます。

  2. フィールドの移動がファンクションキー一発でできます。画面に書いてあるのでそれを押してください。
    チョットひとこと 　TextClipperは、全ての操作について、マウスを使わないでもできるように、工夫されています。

  3. ツリーリストとカードのところで右クリックすると、メニューがでます。また、[Esc]キーでもでます。

  4. タイトルが空の時、タイトルをダブルクリックすると、自動的に設定されます。

  5. グループのフォルダ名や、カードのタイトルに　(&英字)を使用すると、ポップアップリストから選択するときに、キーボードで直接指定できるので便利です。
      例えば、「メモ」という名前のフォルダに、一発ペーストに良く使うカードが有るとします。このとき、フォルダ名を、
        メモ(&M)
    のようにすると、一発ペーストの指定をするとき、フォルダ名リストか出たところで、[M]キーを押すと、「メモ」フォルダが選択状態になります。

  6. TEXT のところで出るメニューの WordWrap は、TEXT の改行の表示方法を切り替えるものです。

  7. TEXT のところで出るメニューのフォントで、TEXT のフォントを変えられます。

  8. ツリーリストのフォルダで、[Shift]を押しながら[右矢印]キーを押すと、その配下のフォルダがすべて開きます。
    逆に[左矢印]キーで閉じます。

  9. タスクトレイ(タスクバーの通知領域)のアイコンを左クリックすると一発ペーストができます。

  10. タスクトレイのアイコンを左でダブルクリックするか　環境設定で設定した新規カードキーでいつでもどこでも新規カード入力ができます。アクティブキーと似ていますがちょっと違います。環境設定によって、最小化して非表示になっているTCを表示するようにもできます。

  11. タスクトレイ(タスクバーの通知領域)のアイコンを右クリック、右ダブルクリックすると一発保存ができます。

    クリックは環境設定でシングルクリックとダブルクリックを切り替えることができます。

    気をつけよう 　マウスを使ってタスクトレイのアイコンをクリックするときは必ず、TCに取り込みたい目的のテキストをアクティブにした状態から一発で行って下さい。
      間違って、周辺を押してしまって目的のソフトがアクティブでなくなると、クリックしてもうまくいきません。そのときは再度目的のソフトをアクティブにしてから行って下さい。
[Keyword]


(TextClipper)FAQ

FAQ

TextClipper　に関する質問をまとめてみました。

Q1．unlha32.dllはどこで入手できますか？
次のホームページにあります。
http://www.csdinc.co.jp/archiver/
など・・・

Q2．一発ペーストに指定できるテキストの件数は最大何件ぐらいですか？その件数はそれぞれのテキストの大きさに左右されますか。
１つのフォルダに３０程度です。
フォルダをうまく使って下さい。

Q3．「データ書き出し」というのは，そのときに TextClipper に保存されているテキスト全部を結合させて１つのデータファイル（TextClip.txt）として書き出すこととして理解していいですか？
そうです。マークを付けたデータを結合して１つのｔｅｘｔファイルにします。

Q4．テキストクリッパーをタスクバーにいろんなソフトを待機させているのと，待機させていない場合に比べて動きが遅くなるという可能性はありますか？今まで使ってみた限りではあまり関係ないようですが。
やはり大きいものをたくさん起動していると、重たくなりますが、それほど気にしないでいいと思います。
普通に使っている分だったら気にしないでいいです。

Q5．Cardのフィールドを右クリックしたときに表示される「タイトルセット」とは何をするためのものですか？
本文でここをタイトルにしたいと思った部分を反転させてそれを実行すると、タイトルの所にはいります。

Q6．保存したそれぞれのテキストをそれぞれ別々のファイルとして保存したいときには，エディターの新規作成画面を立ち上げて，それにそれぞれのテキストを一発ペーストすればよい。これでよろしいですか？もっと簡単にできる方法もありますか？
そうです。
フロッピーには特別にフロッピーボタンがありますのでそれを押すだけでいいです。
ファイル名は勝手に付けます。

Q7．「テキスト読み込み」はできたのですが，「一括テキスト読み込み」の操作法がわかりません。この場合の，複数のテキストファイルの指定の仕方を教えてください。続いて並んでいるファイルだと「Shift＋矢印」でいけるのはわかるのですが，忘れてしまいました。
一括読み込みというのは、１つのテキストファイルに　@@@@@@@@@@@@@@@@@@@
で区切られたデータがあることを前提にしてそれを１つずつのデータとして読み込むものです。複数のファイルを一括でというのはまだありません。

Q8．タスクバーに待機させてある TextClipper の最大化，最小化をキー操作で行うことは可能ですか？可能ならばどうすればよいですか？
環境設定で設定したキー割り当てのアクティブキーで最小化と元のサイズにはできます。最大化はできません。

Q9．ツリーリストのフィールドを右クリックしたときに表示される「出典登録」とは何をするためのものですか？また，どのようにして使うのですか？
出典というのは、一発保存したとき、どのソフトから保存したかというものです。
ｃａｒｄ部に表示。ここを任意のものに変えられます。
ツリー部のタイトルで変えたいデータにマークを付けてこれを実行して、好きな文字を入れてみてください。それに変わってると思います。

Q10．保存できるテキストの件数の限界は何によって決まるのでしょうか？ハードディスクに空きがあればその分だけというふうに理解してよいですか？(階層は10ぐらいまでとのことですが)
一応、データは容量が許す限り大丈夫と思います。
ただ、データ量が増えてくると、立ち上げ時に時間がかかります。
ツリー構造のため、全部のタイトルを読み込んでるので・・・。
一応、testしたら2,000ぐらいはストレス無く使えました。

Q11．テキスト部分のfontを変えるにはどうすればいいのでしょうか？
テキストのところを右クリックするとメニューが現れますのでそこでフォントを選んで下さい。

Q12．キーボードでの操作ができない
  登録を【Shift＋Ctrl＋Ｖ】、一発登録フォルダを【Shift＋Ctrl＋Ｆ】に割り当てていますが、操作するとどちらも×の付いたアイコンが出ます。どのような原因が考えられるでしょうか。

以下の回答は、2007年2月27日 の、どんさんの掲示より転載させていただきました。

  「Ctrl+Shiftを押したままVを押す」→「V押下後、直ぐに３つとも離す。(キーの押し方１)」の操作をしてください。
  V押下後、Vだけ直ぐ離して、他は押しっぱなしにする(キーの押し方２)と、アプリケーションによって、登録出来るものと出来ないものがあります。

参考：確認結果
・動作環境 TextClipper Ver7.800β,XP Pro SP2
一発登録キーを【Ctrl + Shift + V】に設定。
 | キーの押し方１ | キーの押し方２
 | Ctrl+Shiftを押したままVを押す→; V押下後、直ぐに３つとも離す。 | Ctrl+Shiftを押したままVを押す→; V押下後、Vだけ直ぐ離す。他は押しっぱなし。
ブラウザ Sleipnir Ver2.5.9 | 登録OK | 登録OK
ブラウザ Firefox Ver2.0 | 登録OK | 登録NG（Xマーク）
メモ帳 | 登録OK | 登録OK
サクラエディタ | 登録OK | 登録NG（Xマーク）

↑このページのトップに戻る


画面別リファレンス(TextClipper)

画面別リファレンス

ボタンウィンドウ
ツリー部
テキスト部
環境設定ダイアログ

  フィールドの移動がファンクションキー一発でできます。画面(上の赤丸部)に書いてあるのでそれを押してください。
  ツリーリストとカードのところで右クリックすると、メニューがでます。また、[Esc]キーでも出ます。

ファンクションキー | 動作
F1 | ヘルプを表示
F3 | テキスト部にカーソルが有る場合は、「カード内検索」画面を表示。; テキスト検索中の場合は、F3は「次を検索」、Shift＋F3は「前を検索」。
F4 | ツリー部にカーソルが有って、カードにマーク マーク されている場合には、「次のマークにカーソルを移す」。
F6 | ツリー部に、カーソルを移す。
F7 | タイトル入力枠に、カーソルを移す。
F8 | テキスト部に、カーソルを移す。
[Keyword] 画面別リファレンス


画面別リファレンス - ボタンウィンドウ(TextClipper)

ボタンウィンドウ

一発ペースト、一発登録を行うためのボタンを集めたウィンドウです。
ボタンウィンドウを表示するには、環境設定ダイアログの起動時タブで、ボタンウィンドウを使うように設定してください。

ボタン

各ボタンの意味は次の通りです。
ボタンウィンドウ操作部
マウスをドラッグして、ボタンウィンドウを移動することができます。
クリックすると、アクティブウィンドウのタイトルバーにくっついて移動するようになります。

一発ペーストボタン
一発ペーストを行います。
一発ペースト機能

一発登録ボタン
一発登録を行います。
一発登録機能は、TCのデータファイルのデフォルト(既定)フォルダに、カードを連続して登録するために用意されています。
  一発登録フォルダ機能で登録すると、そのフォルダが、デフォルトになります。
一発登録機能

一発登録フォルダボタン
一発登録フォルダ機能を使います。
一発登録機能とほぼ同等ですが、登録先がデフォルトフォルダではなく、毎回自分で選択できる点で異なります。
一発登録機能
  「ここに登録」をクリックします。 すると、選択したテキストが、そのフォルダに登録されます。なお、これ以降このフォルダがデフォルトフォルダとして、 一発登録機能で利用されます。

  「ここのカードに追加」を選ぶとカード一覧が表示されそこで選ぶとそのカードに追加されます。ただしそのカードがテキスト部に表示されている場合や「窓」で開いているときは追加できません。
  このとき[Shift]キーを押しながら行うと、テキストの前に日付と出展が追加されます。
  この機能は表モードの２列のものに追加したときは特別な処理をします。
１行１行でタブが無いか調べ、タブがあればそのまま追加し、無ければダイアログが出てタイトルを入力できるようになります。デフォルトでは選択した文字列が入っています。

クリップツールボタン
クリップツールの一覧が表示されます。
クリップツール

[Keyword] ボタンウィンドウ


画面別リファレンス - ツリー部(TextClipper)

ツリー部

  ツリー部では、フォルダやカードの管理を行います。カードの内容はテキスト部で編集します。
気をつけよう 　新しいフォルダを作れます。階層は一応、１０ほどまでです。それ以上になったときは動作の保証は出来ません。特にフォルダの移動は注意して下さい。
  フォルダ名は１０文字程度までで、スペースは使えません。

ツリー部での操作

  • ツリーリスト内でマウス右クリックするか、[Esc]キーを押すと、ポップアップ(コンテキスト)メニューが表示されます。
    詳しくは、ツリー部ポップアップ(コンテキスト)メニューをご覧ください。
    またよく使うと思われる機能は上部にボタンとして配置しています。
  • カードやフォルダを、マウス左クリックでドラッグ＆ドロップして、別のフォルダに移動できます。カードの順番も任意に変えられます。ただし、一番下には移動できないため下から２番目に移動して一番下のカードを１つ上に移動することで対応して下さい。
  • メニューから移動を選ぶと、カーソルキーでも移動させられます。
  • マーク [image] は、スペースキーを押すかアイコン部分をクリックするとつけられます。フォルダにはマークを付けられません。
  • マークを使うと複数のカードを一度に移動・削除できます。
  • 複数のカードに一度にマークをつけるときは、ポップアップ(コンテキスト)メニューから［マーク関連］を選びます。
  • タイトルをクリックすると、フォルダ名を変更できます。メニューからでも可能です。
  • アイコン部分を右クリックするとアイコンを変更できます。
  • マークボタンで次のマークしてあるカードに移動でします。上に移動するときは[Shift]キーを押しながらです。f4キーでもできます。

ボタン

各ボタンの意味は次の通りです。
常に最前面チェックボックス
チェックを入れると、TCを常に画面の手前に置けるようになります。

新規フォルダボタン
ツリー部に「新規フォルダ」という名前で、新しいフォルダを作ります。
詳しくは、新規フォルダをご覧ください。

マーククリアボタン
すべてのカードのマーク [image] をはずします。

カード検索ボタン
ツリー部から、カードを探します。ボタンを押すと、［検索］ダイアログが表示されます。
詳しくは、カード検索・検索解除をご覧ください。

再読込 再読込ボタン
いま開いているデータを読み込み直します。
詳しくは、再読み込みをご覧ください。

削除ボタン
ツリー部から、フォルダや、カードをTCの「ごみ箱」に移動します。
詳しくは、削除をご覧ください。

マークへボタン
次のマーク [image] がついているカードを表示します。

カード数表示部
黒字は、現在開いているデータに含まれるカードの数です。
赤字は、マークがついているカードの数です。

HTML チェックモード | htmlのソース表示
  バージョン7.8 以降では、ホームページを、ブラウザ「インターネット・エクスプローラ」の画面から取り込んだ場合は、テキストだけではなく、「画像」や「表」付きで保存できるようになりました。
  ただし、スタイル・シートで指定されている、色やフォント形式までは、再現されません。

  この「HTML チェックモード」オプションは、HTMLの表示方法を切り替えるためのもので、通常は、チェックを外しておきます。

  HTMLの内容を、ソース形式で表示したり編集したい場合に限り、ここにチェックを入れます。
メッセージ
  「HTML チェックモード」では、カードの内容をブラウザ表示形式ではなく、HTMLソースコードの形式で表示できるようになります。

  HTML形式で取り込んだカードを選択すると、右のメッセージが表示されます。
  「はい(Y)」をクリックすると、htmlのソースが表示されます。

[Keyword] ツリー部


画面別リファレンス - テキスト部(TextClipper)

テキスト部

  テキスト部では、 カードの内容を編集します。

  カードの基本は、カードの項を参照下さい。
  カードの管理はツリー部で行います。
  フォントは、カードごとに変えることもできます。

テキスト部での操作

  • キーボードを使って、カードの内容を入力したり、編集したりします。
  • 右クリックか[Esc]キーを押すと、ポップアップ(コンテキスト)メニューが表示されます。
      詳しくは、テキスト部ポップアップ(コンテキスト)メニューをご覧ください。

  • URLを記入したところを、ダブルクリックするとブラウザが起動します。
    メールアドレスをダブルクリックするとメールソフトが開きます。
      [Shift]を押しながら[Enter]キーでもできます。
  • 画像やExcelなどのファイルをドラッグしてテキスト部にドロップすることで、ファイルへのリンクを設定することができます。
      このリンクをダブルクリックすると、ファイルの拡張子に関連付けられた当該プログラムを使って、このファイルが表示されます。

  • TCのカード間のリンクも設定できます。

  • テキスト部では、表モードにすると、表形式で表示することができます。例えば、Excelの表の一部を、copy & paste したり、あるいは一発登録したものは、そのまま表モードで表示できます。
チョットひとこと 　入力した内容を元に戻したいとき（undo）には、[Ctrl]+[Z]を使います。戻せるのは、1つ前の状態までです。

ボタン

各ボタンの意味は次の通りです。
簡易エディタ選択ボタン
複数の簡易エディタが表示されているときに、簡易エディタを選ぶことができます。

簡易エディタ編集ボタン
簡易エディタを使って、カードを編集します。

新規カードボタン
ツリー部に「新規カード」という名前で、新しいカードを作ります。

カード削除ボタン
テキスト部に表示しているカードを削除します。

取り消しボタン
カードの内容を、カードを編集する前の状態に戻します。編集しているときに登録ボタンを押していた場合は、登録ボタンを押したときの状態に戻ります。

登録ボタン
カードの内容を登録します。

フロッピーボタン
フロッピーディスクに、カードの内容を保存します。
チョットひとこと ［環境設定］ダイアログで、Floppy Driveを設定すれば、フロッピーディスクに保存できます。
その他タブ

印刷ボタン
テキストの内容を印刷するための、プレビュー画面を表示します。

編集ロック 表,HTML
  チェックを外すと、カードの内容が、テキストのまま(htmlの場合はソース・コードのまま)表示されます。

  「表,HTML」にチェックを入れると、Tab 区切りのテキストが、表形式(表モード)で表示されます。ホームページから取り込んだ場合は、ブラウザで表示したように、「画像」や「表」が、そのまま一体で表示されます。
  ただし、スタイル・シートで指定されている、色やフォント形式までは、再現されません。

  htmlを「HTML チェックモード」で開いて、htmlソースを編集するときは、この「表,HTML」を外して、編集します。
  ブラウザ表示にしたいときは、この「表,HTML」にチェックを入れます。
  「表,HTML」にチェックを入れて保存して、表示すると、ブラウザで表示した場合と同じように表示されます。
気をつけよう 「HTML チェックモード」にチェックを入れずに、htmlを「表,HTML」のチェックを外して編集すると、TCが終了しなくなる場合があります。
  誤って、エラーが表示されて TC が終了しなくなった場合は、タスクマネージャで強制終了して下さい。

編集ロック
  バージョン7.8 以降では、ホームページを、ブラウザ「インターネット・エクスプローラ」の画面から取り込んだ場合は、テキストだけでなく、「画像」や「表」付きで保存できるようになりました。

  環境設定の「その他」の「一発登録したものはロック状態にする」にチェックを入れておくと、一発登録で、TC に取り込んだ場合は、自動的に「編集ロック」にチェックが入ります。

  html の場合は、ツリー部で「HTMLチェックモード」にチェックを入れた場合に限り、「編集ロック」のチェックを外すことができます。
  HTMLの「編集ロック」を外して編集する場合は、テキスト部分のみ編集して、以降このカードは、「表,HTML」のチェックを外しておくことを推奨します。
  htmlのタグや、コードを編集して、「表,HTML」のチェックを入れると、表示動作がどうなるか、保証できません。

  htmlのソースを理解した上で、html部分を編集した場合は、「表,HTML」と「編集ロック」の両方にチェックを入れて、保存します。

タイトル部
カードのタイトルを入力します。
タイトルはツリー部に表示されます。

出典
カードの出典を入力します。
出典名タブ

［ペースト］チェックボックス
カードを一発ペースト機能で使用するときにチェックマークをつけます。

［表］チェックボックス
カードを表形式(表モード)で表示するときにチェックマークをつけます。

［自動タイトル］チェックボックス
  ここにチェックを入れたカードは、タイトルを文章の先頭の内容に自動的に更新できるようになります。
  新規カードを作るときに、［自動タイトル］チェックが入った状態をデフォルトにしたい場合は、環境設定の「その他」で登録します。
気をつけよう 　［自動タイトル］にチェックをすると、カードのタイトルをタイトル部に手動で入力することはできなくなります。1行目の20文字(41バイト)目までが、自動でタイトルになります。

作成日表示
カードを作成した日が表示されます。

更新日表示
カードを更新した日が表示されます。

アイコン選択ボタン
  カードの種類を表すアイコンを、一覧から選択することができます。
  カードの分類や重要度・進行状況をアイコンにすると、分かりやすいでしょう。
  アイコンはツリー部に表示されます。
  アイコンは、カードの検索条件にすることができるので、ToDo 管理にも活用できます。

  ツリー部でアイコンをマウス右クリックしても、アイコン一覧が表示されます。このツリー部のコンテキストメニューでも、アイコンを選択できます。

  アイコンを自分で作りたい場合は、メニューの、「環境設定」→「環境設定」→「カードアイコン」を使います。

カード内次検索ボタン
前回検索した文字列で、ふたたび検索します。
まだ一度も検索してないときは、［検索文字列設定］ダイアログが表示されます。

超一発ペースト割り当てボタン
超一発ペーストのキーを設定します。

リンク

  TC は、テキスト以外のファイルでも、そのファイルへのリンクを登録して、TCでクリックして表示させることができます。TCを、ファイル管理にも活用してみて下さい。

  画像やExcelなどのファイルをドラッグしてテキスト部にドロップすると、例えば次のようにデータ・ファイルへのリンクが登録されます。
<file=C:\WINDOWS\珈琲カップ.bmp>
  このとき、事前に、TCのテキストのリンクを入力したい部分にカーソルを移動させておいてください。ドロップ時に、リンクの挿入位置を指定できません。
  このリンクをダブルクリックすると、ファイルの拡張子に関連付けられたプログラムを使って、このファイルが表示されます。

また
<card=タイトル>
のように登録することで、TCのカード間のリンクができます。
ここをダブルクリックすると、対象のカードが別のwindowで開きます。ダブルクリックするときは、英字(card)の部分を叩くようにしてください。
注：同じタイトルがあれば、どちらかが開きます。リンクするカードは、ユニークなタイトルにしてください。

チョットひとこと 　上の例は、リンクのパス(ファイルのフォルダ指定)がドライブ名も含めて書かれています(絶対参照)。リンクするファイルが、データファイル(textcp7.dat)と同じフォルダにある場合は、下記のようにファイル名のみ(相対参照)に修正することができます。
<file=珈琲カップ.bmp>
  データを他のパソコンに移行したり、複数のパソコンでデータを活用するときに、相対参照にしておくと、データファイルの登録フォルダが異なっていても、パスを修正する必要が無いので便利です。

  例えば、一つのパソコンで、Cドライブの下のフォルダに作ったTCのデータベースを、バックアップを兼ねた別のパソコンでは、Dドライブの下のフォルダに、このTCの同じデータベースのレプリカを作るときに、画像ファイルなどもコピーしておけば、TCのデータを書き換えることなく、リンク参照できます。


テキスト部 簡易エディタ(TextClipper)

簡易エディタ

  TextClipperのテキスト部を独立させることができます。複数のカードを同時に編集するときに使います。
  100個まで開くことができます。

ボタン

各ボタンの意味は次の通りです。
アイコン選択ボタン
カードの種類をあらわすアイコンを、一覧から選択することができます。
アイコンはツリー部に表示されます。

カード内次検索ボタン
前回検索した文字列で、ふたたび検索します。
まだ一度も検索してないときは、［検索文字列設定］ダイアログが表示されます。

登録閉じるボタン
カードの内容を登録して、簡易エディタを閉じます。

登録ボタン
カードの内容を登録します。

簡易エディタ選択ボタン
複数の簡易エディタが表示されているときに、簡易エディタを選ぶことができます。

裏にも行くボタン
簡易エディタが、TextClipperの後ろにも行くようになります。
クリックすると、常にTCの上ボタンが表示されます。

常にTCの上ボタン
簡易エディタが、必ずTextClipperより手前に表示されるようになります。
クリックすると、裏にも行くボタンが表示されます。

キャンセルボタン
簡易エディタが閉じます。
カードの内容は、カードを編集する前の状態に戻ります。編集しているときに登録ボタンを押していた場合は、登録ボタンを押したときの状態に戻ります。

[Keyword] テキスト部
簡易エディタ

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部 置換ダイアログ(TextClipper)

置換ダイアログ

検索文字列（$_Name_のように、$_と_で囲まれた文字列のこと）を含むカードを、一発ペースト機能で一発ペーストしようとすると表示されます。

「$_Name_」を「矢崎」に変更して、差込印刷のようなことができます。

手順

  1. ［置換後］の各行に、置換後の文字列を入力する。

  2. ［OK］ボタンを押す。
    ［置換前］に表示される検索文字列（「$_Name_」など）を、［置換後］に入力した文字列（「矢崎」など）に置換してから、一発ペーストされます。
[Keyword] テキスト部
置換ダイアログ
差込印刷


画面別リファレンス - 環境設定ダイアログ(TextClipper)

環境設定ダイアログ

TextClipperの動作を細かく設定することができます。
［環境設定］ダイアログを表示するには、［環境設定］メニューから［環境設定］を選びます。

詳しくは、各タブのトピックをご覧ください。
出典名タブ
バックアップタブ
その他タブ
キー割り当てタブ
ペーストタブ
カットタブ
コピータブ
起動時タブ
データファイルタブ
ClipToolタブ
カードアイコンタブ
超一発ペースト
[Keyword] 環境設定ダイアログ


環境設定ダイアログ 出典名タブ(TextClipper)

環境設定(O)→環境設定(O)　出典名タブ

出典とは

  TextClipperは、一発登録をしたときに、どのソフトからテキストを持ってきたのか（出典名）を保存します。通常は、そのソフトの「ウィンドウタイトル」が出典名になります。
  ところが、インターネットエクスプローラのように頻繁にウィンドウタイトルが変わるソフトの場合は、ウィンドウタイトルを出典名として利用しづらいことがあります。
  そこで、ソフトごとに出典名を設定できるようにしました。設定できる出典名は最大１０個です。

設定項目

各項目の意味は次の通りです。
出典名
好きな名前を設定できますが、「,（コンマ）」「 （半角スペース）」は使用できません。

Window Class
出典名に対応させたいソフトの、ウインドウクラス名を入力します。「,」でくぎると複数のウィンドウクラスに1つの出典名を対応させることができます。

例（インターネットエクスプローラーの場合）

  たとえばインターネットエクスプローラーの場合、普通はホームページのタイトルがそのまま出典名になります。
  そうではなくて、出典名は「ホームページ」にしたいんだ。という時には、出典名：ホームページ、Window Class：IEFrameと設定すれば、インターネットエクスプローラーから一発登録したときの出典名が、「ホームページ」になります。
[Keyword] 環境設定ダイアログ
出典名タブ


環境設定ダイアログ バックアップタブ(TextClipper)

環境設定(O)→環境設定(O)　バックアップタブ

バックアップ先ファイル：
  データのバックアップファイルを保存する場所と名前を指定します。
  たとえば、DOS/Vパソコン（AT互換機）でフロッピーディスクにバックアップするときは、「A:\TCBACKUP.LZH」などとします。
  ここで指定したフォルダ及びファイル名は完全バックアップ機能で利用されます。
チョットひとこと 　バックアップのファイル名は、データファイル毎に、区分する必要があります。(そうしないと、どれがどのファイルか分からなくなり、復元できない！)

  「A:\TC$BAK.LZH」とすると、$の位置にデータファイル名が挿入されます。たとえば、データファイル名が「サンプル」だとしたら、バックアップ先ファイルは、「A:\TCサンプルBAK.LZH」になります。
  「A:\TC#BAK.LZH」とすると、#の位置にデータファイル番号が挿入されます。たとえば、データファイル番号が1番だとしたら、バックアップ先ファイルは、「A:\TC1BAK.LZH」になります。

  上の画面の例では、バックアップ圧縮ファイル名に、パソコン名(365XやFMV)とデータ名を入れ込んでいます。
気をつけよう バックアップファイルの拡張子はLZHにしてください。
[Keyword] 環境設定ダイアログ
バックアップタブ


環境設定ダイアログ その他タブ(TextClipper)

環境設定(O)→環境設定(O)　その他タブ

新規データ追加位置
新しいカードを、 ツリーリストの「最初に追加」するか「最後に追加」するかを選択します。
これは一時的で並び替え、検索などを行うと任意の順番に置き換えられます。

トレイアイコンのダブルクリック
タスクトレイ(WinXPでは「通知領域」)のアイコンをダブルクリックしたとき、新規カードを開くかＴＣをアクティブにするかを選べます。

Floppy Drive
フロッピーディスクのドライブ名を指定します。 ここで設定したドライブ名は、一発フロッピー書き出しで利用されます。

DOS/Vパソコン(AT互換機)なら[A:]
NEC PC-9821シリーズなら[C:]
と入力すればいいはずです。必ず「:」を含めて 2文字で書いてください。

TEXTの所で自動的にIMEをONにする
チェックがついていると、テキストフィールドに移動したとき、自動的にIMEがONになります。

タスクトレイアイコンをシングル右クリックでフォルダ指定
チェックがついている時と、チェックが外れている時で、[タスク バー] の [通知領域(タスクトレイ)]のアイコンをクリックしたときに呼び出される機能が、次の表のように変わります。

チェックがついているときチェックが外れているとき
右クリック | 一発登録フォルダ機能 | 一発登録機能
右ダブルクリック | 一発登録機能 | 一発登録フォルダ機能
左クリック | 一発ペースト機能 | 同左
左ダブルクリック | 新規カード作成 | 同左
緑で囲んだ部分が、タスクトレイアイコン
テキスト部でタブキーでタブを入力できるようにする
チェックをつけた場合は、テキスト部でタブキーを押すとタブが入力できるようになります。
チェックを外した場合は、テキスト部でタブキーを押すとツリーリストにフォーカスが移ります。

なおチェックに関係なく [Ctrl]+[I(アイ)] でタブを入力することができます。

取り込みでフォルダが違うとき、新しい方のフォルダに変える
［他TextClipper取り込み］で他TextClipperのカードを取り込んだ場合に、今使っているTextClipperのカードと、取り込んだカードが違うフォルダに入っていたとき（他TextClipperで、カードの入っているフォルダが変更されていたとき）は...
チェックをつけたときは、今使っているTextClipperのカードを、取り込んだカードと同じ内容に変更して、取り込んだカードと同じフォルダに移動します。
チェックを外したときは、今使っているTextClipperのカードを、取り込んだカードと同じ内容に変更するだけで、フォルダは移動しません。

クリップボード履歴機能を使う
チェックをつけると、「クリップボード履歴機能」が使えるようになります。MS-Wordで不都合が発生した場合は、ここのチェックを外してみてください。MS-Wordで不具合が発生しなくなることがあります。
クリップボード履歴は20個保存されます。クリップボード履歴が20個を超えた場合は、
新しい履歴→新 0の内容
旧 0の内容→新 1の内容
旧 1の内容→新 2の内容
：→：
旧 Iの内容→新 Jの内容
旧 Jの内容→破棄されます
と順に繰り下げられます。

クリップボード履歴を呼び出すには

  1. タスクトレイアイコンをクリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［ClipBd履歴］を選んで、貼り付けたい履歴をクリックする。

クリップボード履歴を終了時に保存する
チェックをつけると、TextClipper終了時にクリップボード履歴が保存されます。
保存されたクリップボード履歴は、次回TextClipperを起動したときに読み込まれ、クリップボード履歴が再現されます。

非アクティブのフィールドを灰色にする
ここをチェックしておくと、テキスト部にカーソルがないとき、灰色になります。

非表示時の新規カードは窓で開く
ここをチェックしておくと、TextClipperが表示されていないときにショートカットなどで新規カードを作ったとき、窓が開きます。

カード並び替えを自動で行う
チェックを入れると、起動時やデータを再読込するたびに、ツリー部ポップアップメニューで指定した順序に全カードについて自動で並び替えられます。

一発Windowを本体で表示。
ここをチェックしておくと、一発Window が本体で開きます。チェックを外すと窓で開きます。

一発登録フォルダを終了時に記憶
ここをチェックしておくと一発登録したフォルダを終了時にも記憶しておき、次回起動したときにも利用できます。

起動時にツリーを展開させる
チェックを入れると、ツリー部が展開された状態で起動します。チェックを入れないと、最上位のみの状態で起動します。

カードのタイトルを自動で付けるをデフォルトにする
タイトルを、文章の先頭の内容に自動的に更新するようにします。

追加保存listの折り返し数
一発登録でカードに追加するときに使われます。フォルダにカード数が多くなると、メニューの表示がおかしくなるので制限しています。

一発登録したものはロック状態にする
チェックを入れると、一発登録で追加したカードは、カードの右上の「編集ロック」のチェックを外さないと、編集できないように保護します。

WEBからの一発登録はHTMLで保存する
ここにチェックを入れると、ブラウザ(インターネット・エクスプローラ)から一発登録でカードに追加するときに、テキスト・データだけでなく、画像や表も同時に取り込めるようになります。
バージョン7.8 ～で実現した機能です。

[Keyword] 環境設定ダイアログ
その他タブ


環境設定ダイアログ キー割り当てタブ(TextClipper)

環境設定(O)→環境設定(O)　キー割り当てタブ

  用意された6種類の機能を簡単に呼び出すための、ショートカットキーを設定することができます。

ショートカットキーを設定 　テキスト入力部をクリックして、設定したいキー操作をすると、テキスト入力部に設定されたキー操作が表示されます。続いて［OK］ボタンを押すと、キー操作が登録されます。

気をつけよう 　ショートカットキーは、ShiftキーとA、ShiftキーとCtrlキーとAのように、Shiftキー、Ctrlキー、Altキーのどれかと、アルファベットキーの組み合わせで指定します。アルファベットキー単独でショートカットキーを設定することはできません。
  同時に使う他のソフトと、キーの組合せか競合しないように、設定します。
チョットひとこと 　テキスト入力部に、S（半角のエス）だけを入力すると、Shiftキーのダブルクリックが設定されます。同様にCだけを入力すると、Ctrlキーのダブルクリックが、Aだけを入力すると、Altキーのダブルクリックが設定されます。
一発ペーストキー
一発ペースト機能を実行します。
一発ペースト機能

一発登録キー
一発登録機能を実行します。
一発登録機能

一発登録フォルダキー
一発登録フォルダ機能を実行します。
一発登録機能

アクティブキー
TextClipperが、他のウインドウの裏に隠れているときに、このキーを押すと、TCが、最前面に表示されて、入力可能の状態(アクティブ)になります。

クリップツールキー
クリップツールの一覧を表示します。

新規カードキー
すぐに新規カードを開くためのキーです。タスクトレイのアイコンを左でダブルクリックしてもできます。
新しいカードを作り、TextClipperを手前に表示します。

カード検索キー
TextClipperが非表示中でも、このキーを押すと一発で検索windowが開きます。

[Keyword] 環境設定ダイアログ
キー割り当てタブ


環境設定ダイアログ ペーストタブ(TextClipper)

環境設定(O)→環境設定(O)　ペーストタブ

  一発ペースト機能を実行するときの動作を設定することができます。

特殊なペースト方法が必要なソフトのControl Class
標準的なソフトでは、ペースト（貼り付け）をするためには、CTRL+Vを押します。（CTRLキーを押しながらVキーを押す。）
TextClipperの一発ペースト機能は、このキー操作を自動で行う機能とも言うことができます。
ところがソフトによっては、このキー操作ではペーストができません。（たとえばWTERMというソフトでペーストをするには、ALT+E P（ALTキーを押しながらEキーを押して、一旦手を離してからPキーを押す）というキー操作が必要になります。）そのときには当然一発ペースト機能を利用することができなくなります。 そこで、特定のソフトのときには、別のキー操作を自動で行って、一発ペースト機能を実現することにしました。

現在サポートしているキー操作は、ALT+E P（WTERM用）とSHIFT+F9（MIFES用）の2パターンです。また、キー操作を自動で行うのではなく、まったく別の方法で一発ペースト機能を行う、WM_PASTEという項目もあります。
各項目に、特定のソフトのウィンドウクラス名を、キー操作に対応させて入力します。対応させるソフトが複数ある場合は、「,（コンマ）」で区切りって入力します。

履歴を表示
一発ペーストしたカードの利用履歴が10件まで保存されます。
利用履歴は、一発ペースト機能を呼び出したときに表示されます。

クリップボードの履歴も最初に表示
クリップボードの履歴を５個までルートに表示することができます。

デフォルトフォルダを表示する
チェックマークをつけると、一発ペースト機能を呼び出したときに、前回一発ペーストしたカードと同じフォルダに含まれるカードの一覧が表示されます。
チェックマークをはずすと、一発ペースト機能を呼び出したときに、フォルダに含まれるカードの一覧は表示されません。

一発ペーストの後クリップボードを戻す
一発ペースト機能を実行した約1秒後に、クリップボードの内容を一発ペースト機能を実行する直前の状態に戻したいときにチェックマークをつけます。

一発処理時に改行キー対応必要
ここはデフォルトではチェックが入っています。
チェックを外すと若干一発処理が早くなります。その時、次に事を確認してください。
メモ帳などのエディタを開いてＩＭＥをＯＮにして漢字変換を行いエンターで確定します。
そこでボタンウィンドウで一発ペーストします。このときさっきのエンター以降はキーボードは使わないようにします。
この一発ペーストの時に、最初に勝手に改行が入らなければチェックは外しておいて大丈夫です。
入る場合は必ずチェックしておいてください。ＷＥＢ上のフォーム登録では特に困ることになります。

戻したくないWINDOW Class
［一発ペーストの後クリップボードを戻す］にチェックマークをつけた場合に、特定のソフトでトラブルが発生したときに設定します。
トラブルが発生するソフトのウィンドウクラス名を入力します。複数ある場合は、「,（コンマ）」で区切りって入力します。

上のフィールドをダブルクリックすると追加
［特殊なペースト方法が必要なソフトのControl Class］の各テキストボックスをダブルクリックすると、コントロールクラスを簡単に入力することができます。
詳しくは、クラス名の取得をご覧ください。

気をつけよう
  • ［特殊なペースト方法が必要なソフトのControl Class］は、一発ペースト機能が利用できないときに設定します。 通常は設定しないでください。
  • WTERMなどの通信ソフトのようにペーストに時間がかかるソフトの場合は、［一発ペーストの後クリップボードを戻す］にチェックマークをつけると、トラブルが発生することがあります。
    トラブルが発生するソフトがわかったときは、［戻したくないWINDOW Class］を設定すると、トラブルの発生を防ぐことができます。
チョットひとこと ［戻したくないWINDOW Class］は、［一発ペーストの後クリップボードを戻す］にチェックマークをつけて、トラブルが発生するソフトがわかった場合に設定します。

関連項目

ウィンドウクラス名やコントロール名を調べる
[Keyword] 環境設定ダイアログ
ペーストタブ


環境設定ダイアログ カットタブ(TextClipper)

環境設定(O)→環境設定(O)　カットタブ

  ここは普通は設定の必要はありません。

  コピータブの説明を参照下さい。
特殊なカット方法が必要なソフトのControl Class
ペーストタブの［特殊なペースト方法が必要なソフトのControl Class］と同様に設定します。

上のフィールドをダブルクリックすると追加
［特殊なカット方法が必要なソフトのControl Class］の各テキストボックスをダブルクリックすると、コントロールクラスを簡単に入力することができます。
詳しくは、クラス名の取得をご覧ください。
[Keyword] 環境設定ダイアログ
カットタブ


環境設定ダイアログ コピータブ(TextClipper)

環境設定(O)→環境設定(O)　コピータブ

  ここは普通は設定の必要はありません。

  通常、コピーはctrl+c　ペーストはctrl+vを使っています。
  ソフトによって、これではペーストやコピーができないときがあります。 WTERMはALTを押しながらEを押してpを押さないとペーストできません。
  このような場合に、ここにそのコントロールのクラス名を書いておきます。複数ある時は「,」で区切ってかいてください。コントロールのクラスは同じウインドウ上でも、違う場合がありますので、必要なときはそれぞれを設定して下さい。
  うまくいかないときはとりあえず一番下の、WM_XXXXに設定してみて下さい。 ほとんどの場合、うまくいくと思います。そして早いです。 こちらを標準にしようとしたのですが、やはりCTRL+Vなどのサポートが多かったため、やめました。IEやNIFTY　MANAGERなど、うまくできないときは、ここを設定すると良いでしょう。
特殊なコピー方法が必要なソフトのControl Class
ペーストタブの［特殊なコピー方法が必要なソフトのControl Class］と同様に設定します。

上のフィールドをダブルクリックすると追加
［特殊なコピー方法が必要なソフトのControl Class］の各テキストボックスをダブルクリックすると、コントロールクラスを簡単に入力することができます。
詳しくは、クラス名の取得をご覧ください。

一発登録時のテキストへの保存情報
  ブラウザから、ホームページのテキストを登録したときに、ここでチェックを入れた項目も、合わせて自動で、TCに保存されます。
  例えは、URLにチェックを入れておくと、
★入手先URL=http://makotowatana.ld.infoseek.co.jp/text2.html
のように登録されるので、簡単に再度そのホームページにTCから接続できるようになって便利です。
[Keyword] 環境設定ダイアログ
コピータブ


特殊な機能 - クラス名の取得(TextClipper)

クラス名の取得

  環境設定ダイアログで入力するウィンドウクラス名とコントロールクラス名は、次のようにして取得します。

手順

  1. 環境設定ダイアログを閉じる。

  2. ウィンドウクラス名とコントロールクラス名を取得したいソフトに、一発ペーストする。
    たとえば、インターネットエクスプローラに一発ペーストします。
    なにも貼り付けられないときは、何度か一発ペーストしてください。

  3. 環境設定ダイアログを開く。
    ［OK］ボタンの上にある、「WindowsClass」に続く単語がウィンドウクラス名、 「ControlClass」に続くものがコントロールクラス名です。（下図参照）

    インターネットエクスプローラーのURL部分に一発ペーストしたときは、 ウィンドウクラス名は「IEFrame」、コントロールクラス名は「Edit」です。
[Keyword] 特殊な機能
クラス名の取得

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


クラス名の取得 ウィンドウクラス名とは(TextClipper)

ウィンドウクラス名とは

  ウィンドウクラス名は、ウィンドウを区別するための名前です。通常、ソフトごとに異なるウィンドウクラス名がついているので、TextClipperではソフトを見分けるときに利用しています。

  ウィンドウクラス名が要求されるのは、環境設定ダイアログの出典名タブの［Window Class］と、 ペーストタブの［戻したくないWINDOW Class］の2ヶ所です。

関連項目

環境設定ダイアログの出典名タブ
環境設定ダイアログのペーストタブ
[Keyword] 特殊な機能
クラス名の取得
ウィンドウクラス名とは

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


クラス名の取得 コントロールクラス名とは(TextClipper)

コントロールクラス名とは

コントロールクラス名は、コントロール（テキストボックスや、コンボボックスなど）を区別するための名前です。ウィンドウクラス名よりも、細かいコントロールを見分けるときに利用しています。

コントロールクラス名が要求されるのは、 環境設定のペーストタブ、カットタブ、コピータブの、［特殊なxxxx方法が必要なソフトのControl Class］です。

関連項目

環境設定ダイアログのペーストタブ
環境設定ダイアログのカットタブ
環境設定ダイアログのコピータブ
[Keyword] 特殊な機能
クラス名の取得
コントロールクラス名とは

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


環境設定ダイアログ 起動時タブ(TextClipper)

環境設定(O)→環境設定(O)　起動時タブ

TextClipperの表示形式を変更することができます。

アイコン状態で起動
起動直後は、アイコンだけを表示したいときに、チェックマークをつけます。
スタートアップに登録しているときにチェックマークをつけます。

ボタンウィンドウを使う
ボタンウィンドウを使うときに、チェックマークをつけます。
ボタンウィンドウを使うと、一発ペースト機能、一発登録機能を簡単に呼び出すことができます。

ボタンウィンドウをタイトルバーにのせる
アクティブウィンドウのタイトルバーに、ボタンウィンドウをのせたいときに、チェックマークをつけます。
アクティブウィンドウに関係なく画面の特定の場所に、ボタンウィンドウを表示したいときは、チェックマークをはずします。
［ボタンウィンドウを使う］にチェックマークをつけたときに設定できます。

タスクバーに表示
通常のソフトウェアのように、タスクバーに表示したいときに、チェックマークをつけます。
タスクバーには表示しないときは、チェックマークをはずします。
タスクバーに表示しないときでも、タスクトレイ(タスクバーの通知領域)アイコンは表示されます。

[Keyword] 環境設定ダイアログ
起動時タブ


環境設定ダイアログ データファイルタブ(TextClipper)

環境設定(O)→環境設定(O)　データファイルタブ

  ファイル切り替えで切り替えるデータファイルを登録します。
  データファイルは１つのディレクトリに１つしか置くことができません。

データファイルを登録する手順

  1. 登録したいデータファイル番号の、データ名称欄をダブルクリックする。
      任意の行をダブルクリックします。すると、下の図の［設定］ダイアログが表示されます。
      (№1のフォルダは変更できません。デフォルトとして使います。)

  2. ［データ名称］を入力する。
      下の図の例は、「データ名称」として、address_bookを入力しています。
      ［データ名称］は［ファイル切り替え］を選んだときに表示されます。
      右の図の例は、№2に「日記」というデータ名称を付けてあります。

  3. ［パス］を選ぶ。
      データファイルは１つのフォルダに１つしか置くことができません。新規にデータをおいておくディレクトリをあらかじめ作っておきます。存在しないフォルダを指定することはできません。

      データファイルを登録するフォルダを選びます。
      上の図の、下の横長の窓で、ドライブを選択します。上の図では、「Dドライブ」を選択しています。
      ドライブ名以下のディレクトリーは、真ん中の「パス」の部分で選択します。上の図で、Dドライブの直下の他のフォルダを表示させたいときは、「D:\」の部分をダブルクリックすると表示されます。
      選んだフォルダにデータファイルがないときは、新しくデータファイルを作るか選ぶことができます。

      新規の場合は、新規かどうか聞いてくるので、［YES］を押すと、そのフォルダに新規のファイルが作られます。

    チョットひとこと 　環境によって新規のデータファイルを作れないことがあります。そのときは同梱してあるdata.lzhをその新しいディレクトリに解凍してから、ここで設定するとうまくいきます。

  4. ［OK］を押す。
    ［設定］ダイアログが閉じて、データファイルが作成されます。

データファイルをクリアする手順

  1. 登録したいデータファイル番号の、データ名称欄をクリックする。
    クリックしたデータ名称欄が、点線で囲まれます、

  2. ［クリア］を押す。
    データファイルが削除されます。
[Keyword] 環境設定ダイアログ
データファイルタブ


環境設定ダイアログ ClipToolタブ(TextClipper)

環境設定(O)→環境設定(O)　ClipToolタブ

  現在インストールされているクリップツールと、クリップツールのファイル名を一覧で表示します。

クリップツールのインストールとアンインストール

  クリップツールは、拡張子が *.cta のファイルです。(解説の txt ファイルや、ソース *.c などが付いている場合も有ります。)
  標準以外のクリップツールは、下記のホームページ
http://hp.vector.co.jp/authors/VA001032/textclip.html
に掲載されています。必要に応じてダウンロードして、TextClipperのプログラムと同じフォルダに解凍すれば、次回にTCを起動したときに、自動でインストールされます。

  使いたくなければ、TCが起動していないときに、拡張子を適当に変更(例えば、*.STOPcta)するだけです。永久に使わないのなら、削除するだけです。
[Keyword] 環境設定ダイアログ
ClipToolタブ


環境設定ダイアログ カードアイコンタブ(TextClipper)

環境設定(O)→環境設定(O)　カードアイコンタブ

  カードのアイコンを自分の好きなものに変更できます。
  ビットマップ最大100個を、登録することができます。登録したビットマップは、カードのアイコンとして利用することができます。

  アイコンは 16X16 ドットの bmp ファイルで、バックが白のものを準備して下さい。

  カードのアイコンについては、テキスト部のアイコン選択ボタンをご覧ください。

手順

  1. 変更したいカードのアイコン、またはアイコンの未登録部分(白いノートデザインのアイコン)をダブルクリックする。
    ファイルを開くダイアログが表示されます。

  2. ビットマップファイルを選んで、［開く］を押す。
    ビットマップが登録されます。
    登録したアイコンはTextClipperのフォルダに、cardicon.bmpで管理されます。
    cardicon.bmpを作り直すため、登録時に数秒ですが時間がかかります。
アイコンを作ろう
  1. ペイントを起動→表示→拡大→拡大率の指定→800％
  2. 表示→拡大→グリッドを表示→16X16または、15x15の大きさにする。
    15x15にするとカードを開いているとき"透き通る"ことがないようです。
    文字アイコンを作る場合は、一文字をコピーして、ペイントに貼り付けると簡単に作成できます。
  3. デザイン終了後は、名前を付けて、分かりやすいフォルダに保存する。
    TextClipperのデータファイルのフォルダに保存すると、TextClipperでファイル管理できます。
  アイコンのサンプルを、下記のホームページの左目次の一番下に貼り付けて有ります。よろしければダウンロードして下さい。
  また、便利なアイコンができたら送って下さい。掲示に追加します。
http://www.hi-ho.ne.jp/makoto_watanabe/tc/
チョットひとこと 　複数のパソコンで、登録したアイコンを共通に使う場合は、
  1. 先に登録済みのパソコンの、TextClipper のフォルダに有る cardicon.bmp をフロッピなどにコピーする。
  2. 新しく追加したいパソコン側の TextClipper が起動していない状態で、フロッピなどから、 cardicon.bmp を、新しく追加したいパソコン側の TextClipper のフォルダに上書きコピーします。
  このとき、新しく追加したいパソコン側に、既に別のアイコンが登録してあると、上書きで消えてしまうので、前もって複数のパソコンのアイコン登録を同じ状態にそろえたうえで、メインマシン→サブマシンという流れで、作業すると良いでしょう。
[Keyword] 環境設定ダイアログ
カードアイコンタブ


環境設定ダイアログ 超一発ペースト(TextClipper)

環境設定(O)→環境設定(O)　超一発ペースト

超一発ペースト機能とは

  任意のキーに１つのカードを割り当て、そのキーを押すと割り当てたカードがペーストされるというものです。
  一発ペーストよりも早くカードをペーストできます。（９つまで登録可能）

手順

  1. 「環境設定」の「超一発ペースト」のタブでショートカットキーを設定します。
      ショートカットキーは、画面の例のように、[Ctrl]+[数字]が、カードの選択画面と合致するので、分かりやすいでしょう。

      一番上は１つ前にペーストしたカードをペーストするときに使うものです。
  2. 定型文句のカードを作成します。

      TextClipperのメインの画面に超一発ペーストさせたいカードを作ります。
      すでにできているなら、そのカードを表示させます。

      そして「表」のチェックボタンの下のボタン [image] を押します。
      するとキー一覧が表示されますので、そこで割り当てたいキーを選びます。
  3. 設定て済みのカード(テキスト)を貼り付けたいところで、そのキーを押します。
    カードがペーストされます。

例：

  下図のような、日記の項目のひな形のカード(カードタイトル：テンプレート)を作っておいて、超一発ペーストに登録すると、毎日の日記を付けるときに、ショートカット(この例では、[Ctrl]+[1])で貼り付けできます。

＜参考追記＞
  1. TCで簡単な健康日記を付けると、キーワード検索で、症状と季節の関係や、症状間の相関などの、傾向・パターンを調べることができます。ちょっとしたテキスト・マイニング（data mining）です。
  2. 写真や資料は、リンク貼り付けします。
  3. フォルダ名とカードタイトルを年月の数字にしてあるので、日記を付け忘れて (^^ゞ カード作成日が前後しても、順番は正しく日付順に並びます。
  4. 上の例では、睡眠時間の項目の右に少し離れてカーソルが見えると思います。項目と記入内容の間に、「タブ」を入れているのです。こうすると、Excelに一発ペーストしたときに、項目と内容が、セルが分かれて貼り付きます。
  5. テンプレートを作って、項目を統一して書き続けておくと、TCからカード書き出ししたテキストの数値を、Excelのマクロで取り込んで、例えば血圧の推移グラフを書くこともできます。
  6. テキスト部の背景色を黒にすると、画面がまぶしくなく、文字が見やすいので、長時間見ていても目が疲れません。
  7. 会社や学校の業務日誌などの場合は、曜日や日付で記入担当を決めて、それぞれのパソコンで作ったものを、後で結合してまとめ上げることもできます。この場合は、マージした後、違うパソコンで、同一日の内容に違う修正を加えないように注意します。(修正したら、直ぐに全員のパソコンのデータを更新しておけば、問題有りません。)


メニュー別リファレンス(TextClipper)

メニュー別リファレンス

［ファイル］メニュー
［編集］メニュー
［検索］メニュー
［入出力］メニュー
［環境設定］メニュー
［ヘルプ］メニュー
ツリー部ポップアップ(コンテキスト)メニュー
テキスト部ポップアップ(コンテキスト)メニュー
[Keyword] メニュー別リファレンス


［ファイル］メニュー(TextClipper)

［ファイル］メニュー

ファイル切り替え
印刷
一時バックアップ
完全バックアップ
終了
[Keyword] ファイルメニュー


［ファイル］メニュー - ファイル切り替え(TextClipper)

ファイル(F)→ファイル切り替え

  TextClipperは、標準のデータファイルを textclip.exe と同じフォルダに作って、カードをそのファイルに保存しています。
  しかし、カードが多くなった場合、標準のデータファイルだけでは、カードの管理が煩雑になってしまうことがあります。
  そんなときは、カードを複数のデータファイルに分けて、カードを管理しましょう。
チョットひとこと 　TCのカード検索は、一つのファイル内での検索になります。
  このため、一つのキーワードで検索したいカード群は、一つのファイルにまとめておいたほうが便利です。
  ファイル内での分類は、フォルダを使って区分します。

  逆に、内容の属性が異なるカード群は、別のファイルにします。

  右上の画面の例では、通常の記事のスクラップ用の「データ１」ファイルと、個人の「日記」のファイルは、内容が違うデータなので、ファイルを分けています。
気をつけよう 　複数のデータファイルを使うには、まずフォルダを作って設定する必要があります。データファイルをつくるには、環境設定ダイアログのデータファイルタブを使います。

手順

  1. ［ファイル］メニューから［ファイルの切り替え］を選ぶ。
    すでに登録されているデータの一覧が表示されます。

  2. 一覧から切り替えたいデータを選ぶ。
    データが切り替わり、ツリー部の表示が変わります。

関連項目

データファイルを作るには - データファイルタブ
[Keyword] ファイルメニュー
ファイル切り替え


［ファイル］メニュー - 印刷(TextClipper)

ファイル(F)→印刷

  プレビュー画面を見ながら、フォントサイズや余白などを設定できます。表にも対応しています。

手順

  1. ［ファイル］メニューから［印刷］を選ぶ。
      あるいは、テキスト画面の右上の印刷ボタンを押す。
      もしくは、テキスト部のポップアップ(コンテキスト)メニューで［印刷］を選ぶ。

      開いているカードの内容が、プレビュー画面で表示されます。
    チョットひとこと 　テキスト画面で、文節などの範囲を選択状態(マウスでこすって、文字を反転させる)にすると、その範囲だけを印刷することができます。
      これは、TCのユニークな特長です。

  2. フォントサイズや行間の広さや余白を調節します。

    プレビューで確認したら「印刷」ボタンを押します。
ひとこと 　プリンタはデフォルトのプリンタが選択されています。
  変更したい場合は、ここで設定します。印刷方向も、必要ならば「プリンタ設定」で変更しましょう。
[Keyword]


［ファイル］メニュー - 一時バックアップ(TextClipper)

ファイル(F)→一時バックアップ

  データのバックアップファイルを、TCの該当データファイルと同じフォルダに作ります。
  バックアップファイル名は「TCBkup7.LZH」です。

  完全バックアップとの違いは、保存先と圧縮ファイル名が違うだけで、作られるデータは同じです。

手順

  1. ［ファイル］メニューから［一時バックアップ］を選ぶ。
      データのバックアップファイルを作ります。
      バックアップファイル名は「TCBkup7.LZH」です。今開いているデータファイルと同じフォルダに作られます。

データを復元する

  バックアップしたデータを復元するときは、バックアップファイル「TCBkup7.LZH」を解凍して、得られたファイル(totextcp.dat)を、分かりやすいフォルダに解凍します。
  「入出力」→「他TextClipper 取り込み」をします。
  複数のデータを使っていたときは、取り込むファイルを間違えないようにしてください。
[Keyword] ファイルメニュー
一時バックアップ


［ファイル］メニュー - 完全バックアップ(TextClipper)

ファイル(F)→完全バックアップ

  データのバックアップファイルを作ります。
  バックアップ圧縮ファイル名および、バックアップファイルが作られるフォルダは、「環境設定」の「バックアップタブ」で指定します。

  完全バックアップで作成したファイルは、「他TextClipper取り込み」で、他のパソコンのTCに取り込むことかできます。

手順

  1. ［ファイル］メニューから［完全バックアップ］を選ぶ。
    データのバックアップファイルを作ります。
    バックアップファイル名および、バックアップファイルが作られるフォルダは、環境設定のバックアップタブで指定します。
気をつけよう
  1. TCの「データ」とは、「環境設定」→「環境設定」→の「データファイル」で登録したグループのことです。
  2. 「完全バックアップ」でバックアップされるのは、そのとき表示しているデータファイルだけです。データファイル毎に、「完全バックアップ」する必要があります。
  3. TCで、カード検索した状態で、「完全バックアップ」すると、検索してマーク マーク されたカードだけのバックアップができます。
      ファイル全体をバックアップするために、一度「 再読込 」してから、「完全バックアップ」すると良いでしょう。
  4. 複数のファイルを使っている場合は、バックアップは、データファイル毎に別の名前で保存するか、あるいは違うフォルダに保存して、どのデータファイルのバックアップか、区分できるようにしましょう。

データを復元する／他のパソコンのTCに取り込む

  バックアップファイルを、「他TextClipper取り込み」で、取り込むための、指定フォルダに解凍します。
  「入出力」→「他TextClipper取り込み」をします。
  複数のデータを使っていたときは、取り込むファイルを間違えないようにしてください。
[Keyword] ファイルメニュー
完全バックアップ


［ファイル］メニュー - 終了(TextClipper)

ファイル(F)→終了

TextClipperを終了します。

手順

  1. ［ファイル］メニューから［終了］を選ぶ。
    TextClipperを終了します。
[Keyword] ファイルメニュー
終了


［編集］メニュー(TextClipper)

［編集］メニュー

コピー
切り取り
貼り付け
新規フォルダ
新規カード
削除済みカード
[Keyword] 編集メニュー


［編集］メニュー - コピー(TextClipper)

編集(E)→コピー

テキスト部で反転表示されているテキストを、クリップボードにコピーします。
気をつけよう カードやフォルダは、コピーできません。

手順

  1. テキスト部で、コピーしたいテキストを選ぶ。

    選んだテキストが反転表示されます。
    テキストの選択方法 下記のいずれかの操作をします。
    1. マウスだけで選択する方法(少ない範囲を選択するとき有効)：
        マウス・ポインタを、選択したい範囲の、開始部分(もしくは終了部分)に持っていって、左クリックします。そして、左クリックしたまま、マウスで、終了部分(もしくは開始部分)まで動かします(左クリックしたまま、マウスで こする 感じ)。行き過ぎた場合は、マウスで左クリックしたまま、戻します。思った範囲が反転したら、マウス左から指を離します。

    2. マウスとキーボードを使う方法(何行にもわたる範囲を指定するときに有効)：
        選択したい範囲の開始部分(もしくは終了部分)でマウス左クリックします。カーソルがその部分で点滅します。次に、マウスをクリックしないで、マウス・ポインタを、選択したい範囲の、終了部分(もしくは開始部分)まで動かします。そして、[Shift]キーを押しながら、マウスで左クリックします。思った範囲と違った場合は、[Shift]キーを押したまま、マウス左クリックの指を離して、マウスポインタの場所を変えて、再度マウス左クリックします。この間、[Shift]キーを押したままで操作します。思った範囲が反転したら、[Shift]キーと、マウス左から指を離します。

    3. キーボードだけで選択する方法：
        選択したい範囲の開始部分(もしくは終了部分)でマウス左クリックします。カーソルがその部分で点滅します。そして、[Shift]キーを押しながら、矢印キー[→↓など]で、カーソルを動かして、終了部分(もしくは開始部分)まで動かします。行き過ぎた場合は、矢印キー[←↑など]で、戻します。この間、[Shift]キーを押したままで操作します。思った範囲が反転したら、[Shift]キーから指を離します。

    範囲選択のコツ：他のソフトでも同じですが、一般に、範囲選択する場合は、「開始部分→終了部分」と選択するより、「終了部分→開始部分」と、お尻から選択するほうが、思ったように選択し易いようです。

    • ［編集］メニューから［コピー］を選ぶ。
        もしくは、
    • テキスト部を右クリックして、ポップアップ(コンテキスト)メニューから［コピー］を選ぶ。
        もしくは、
    • 左手小指で、[Ctrl]を押しながら、左手の中指か人差し指で、[C]を押して、左手を上げる。(←キーボードを使ったこの方法が、最も簡単なので、推奨します。) )

    手順1で選んだテキストが、クリップボードにコピーされます。

参考

  コピーしたテキストの貼り付け方法


［編集］メニュー - 切り取り(TextClipper)

編集(E)→切り取り

テキスト部で反転表示されているテキストをクリップボードにコピーして、テキスト部から削除します。
気をつけよう カードやフォルダは切り取ることができません。

手順

  1. テキスト部で、切り取りたいテキストを選ぶ。
    選んだテキストが反転表示されます。
    SHIFTキーを押しながら、カーソルキーで選ぶことができます。
    マウスをドラッグして選ぶこともできます。

  2. ［編集］メニューから［切り取り］を選ぶ。
    手順1で選んだテキストがクリップボードにコピーされて、テキスト部から削除されます。
[Keyword] 編集メニュー
切り取り


［編集］メニュー - 貼り付け(TextClipper)

編集(E)→貼り付け

テキスト部のカーソル位置に、クリップボードのテキストを貼り付けます。
気をつけよう 　貼り付け先のテキスト部で、テキストが反転表示されているときは、反転表示されている部分が、クリップボードの内容で置き換えられます。

手順

  1. テキスト部で、テキストを貼り付けたい場所に、カーソルを動かす。

      マウスで、貼り付けたい場所に、マウスポインタを動かします。マウスで左クリックして、カーソルを位置付けます。
      矢印キー[→][↓][↑][←]で、カーソルを動かすこともできます。

    • ［編集］メニューから［貼り付け］を選ぶ。
        もしくは、
    • テキスト部を右クリックして、ポップアップ(コンテキスト)メニューから［貼り付け］を選ぶ。
        もしくは、
    • 左手小指で、[Ctrl]を押しながら、左手の人差し指で、[V]を押して、左手を上げる。(←最も簡単なので、この方法を推奨します。)

    カーソル位置に、クリップボードのテキストが貼り付けられます。
チョットひとこと 　Webブラウザ等の、特定のソフトの場合は、表示中の特定ソフトの文字情報を、コピー操作をしないで、ドラッグ＆ドロップで、TCに直接、貼り付けることもできます。


［編集］メニュー - 新規フォルダ(TextClipper)

編集(E)→新規フォルダ

ツリー部に「新規フォルダ」という名前で、新しいフォルダを作ります。

手順

  1. ツリー部で、新規フォルダを作りたい場所にカーソルを動かす。
    カーソルキーで動かすことができます。
    マウスでクリックして、カーソルを動かすこともできます。

  2. ［編集］メニューから［新規フォルダ］を選ぶ。

    もしくは、ツリー部のポップアップ(コンテキスト)メニューから［新規フォルダ］を選ぶ。
    カーソル位置に、「新規フォルダ」という名前のフォルダが作られます。
気をつけよう 　すでに、「新規フォルダ」という名前のフォルダがあるときは、新しいフォルダを作ることができません。
  「新規フォルダ」の名前を変えてから、もう一度新規フォルダを作ってください。
気をつけよう 　階層の深さ(親→子→孫・・のレベル)は、一応１０ほどまでです。それ以上になったときは動作の保証は出来ません。
  同一レベル(兄弟姉妹)のフォルダは、多くてもかまいません。
[Keyword] 編集メニュー
新規フォルダ


［編集］メニュー - 新規カード(TextClipper)

編集(E)→新規カード

ツリー部に「新規カード」という名前で、新しいカードを作ります。

手順

  1. ツリー部で、新規カードを作りたい場所にカーソルを動かす。
    カーソルキーで動かすことができます。
    マウスでクリックして、カーソルを動かすこともできます。

  2. ［編集］メニューから［新規カード］を選ぶ。
    カーソル位置に、「新規カード」という名前のフォルダが作られます。

  3. テキスト部に、カードの内容を書き込む。

  4. テキスト部の上にある［登録］ボタンを押す。
    カードが登録され、［登録］ボタンが押せなくなります。
[Keyword] 編集メニュー
新規カード


［編集］メニュー - 削除済みカード(TextClipper)

編集(E)→削除済みカード

削除済みカードの一覧を表示します。
カードをツリー部に復活させることができます。
カードを復活できないように、完全に削除することもできます。

削除したカードを復活させる手順

  1. ［編集］メニューから［削除済みカード］を選ぶ。
    もしくは、ツリー部のポップアップ(コンテキスト)メニューから［削除済みカード］を選ぶ。
    ［削除済みカード］ダイアログが表示されます。
    削除済みカードが無い場合は、［警告］ダイアログが表示されます。
  2. 削除済みカードの一覧から、復活させたいカードを選ぶ。
    復活させたいカードのタイトルの左にあるチェックボックスをクリックして、チェックをつけます。

  3. ［復活］ボタンを押す。
    削除したカードが、ツリー部に復活します。

削除したカードを完全に削除する手順

  1. ［編集］メニューから［削除済みカード］を選ぶ。
    もしくは、ツリー部のポップアップ(コンテキスト)メニューから［削除済みカード］を選ぶ。
    ［削除済みカード］ダイアログが表示されます。
    削除済みカードが無い場合は、［警告］ダイアログが表示されます。

  2. 削除したいカードにチェックを入れる。
    完全に削除したいカードのタイトルの左にあるチェックボックスに、チェックを入れます。
  3. ［全マーク］ボタンを押す。
    すべてのカードを削除したい場合は、［全マーク］ボタンを押すと、カードのタイトルの左にあるチェックボックスにチェックがつきます。

  4. ［完全削除］ボタンを押す。
    ［注意］ダイアログが表示されます。

  5. ［はい］を押す。
    チェックを付けたカードが完全に削除されます。
気をつけよう 　完全削除は、ゴミ箱に移動してある、削除済みのカードを、完全に削除する機能です。
[Keyword] 編集メニュー
削除済みカード
削除したカードを元に戻す


［検索］メニュー(TextClipper)

［検索］メニュー

  カード検索からカード内検索まで、同一のキーワードで連続して検索できます。
  カード検索では、「現在のフォルダを検索」にマークを入れると、当該フォルダ内のみ検索します。

カード内検索
カード内置換
カード検索
検索解除
[Keyword] 検索メニュー


［検索］メニュー - カード内検索(TextClipper)

検索(S)→カード内検索

テキスト部から、単語を探します。

手順

  1. ［検索］メニューから［カード内検索］を選ぶ。
    検索文字列設定ダイアログが表示されます。

  2. ［検索文字列］入力欄に、テキスト部から探したい単語を入力する。

  3. ［OK］ボタンを押す。
    検索が始まります。
    単語が見つかったときは、見つかった単語が反転表示されます。
[Keyword] 検索メニュー
カード内検索


［検索］メニュー - カード内置換(TextClipper)

検索(S)→カード内置換

テキスト部の単語を、別の単語に置き換えます。

手順

  1. ［検索］メニューから［カード内置換］を選ぶ。
    ［置換］ダイアログが表示されます。

  2. ［検索文字列］入力欄に、置き換える前の単語を入力する。

  3. ［置換文字列］入力欄に、置き換えた後の単語を入力する。

  4. （必要なら）［大文字小文字を区別］にチェックマークをつける。
    チェックマークをつけると、大文字と小文字を別の文字と見なします。
    チェックマークをつけないと、大文字と小文字を同じ文字と見なします。

  5. ［OK］ボタンを押す。
    置換が始まります。
    ［検索文字列］入力欄に入力した単語が見つかったときは、その単語が反転表示され、［確認］ダイアログが表示されます。

    ［検索文字列］入力欄に入力した単語が見つからなかったときは、エラー音が鳴って、置換は終了します。

  6. いずれかのボタンを押す。
    ［置換］ボタンを押すと、反転表示されている単語を、［置換文字列］入力欄に入力した単語に置き換えます。
    ［次検索］ボタンを押すと、反転表示されている単語は、置き換えません。もう一度［検索文字列］入力欄に入力した単語を検索します。
    ［全置換］ボタンを押すと、すべての［検索文字列］を［置換文字列］に置き換えます。
    ［Cancel］ボタンを押すと、置換処理を終了します。
[Keyword] 検索メニュー
カード内置換


［検索］メニュー - カード検索・検索解除(TextClipper)

検索(S)→カード検索・検索解除

  ツリー部から、カードを探します。
  特定の単語が含まれているカードを探したり、カードを作った日、カードを更新した日、出典などを頼りにカードを探します。
  見つかったカードにはマーク 赤いチェック がつけられます。
  マーク移動ボタン [image] で次のカードに一発で移動できます。

  カード検索して、カードを開いた後は、テキスト部の、カード内次検索ボタン [image] で、該当部分を次々と表示させることができます。

手順

  1. ［検索］メニューから［カード検索］を選ぶ。
    ［検索］ダイアログが表示されます。

      「カード検索」ボタン [image] を押しても同じダイアログが開きます。

      ツリー部ポップアップ (ツリー部を右クリックして表示される、ポップアップ(コンテキスト)メニュー)で、［カード検索］を選んでも同じダイアログが開きます。
  2. カードを探す条件を入力する。
    2-1.探す単語 入力した単語が含まれるカードだけが、ツリー部に表示されます。
    半角スペースまたは全角スペースで区切って複数の単語を入力できます。

    2-2.複数指定時の検索方法 2-1.で半角スペースまたは全角スペースで区切って複数の単語を入力したときに、

    • And検索
        入力したすべての単語が含まれるカードだけが、ツリー部に表示されます。
    • Or検索
        入力した単語のどれかひとつが含まれるカードだけが、ツリー部に表示されます。

    2-3.あいまい検索 大文字、小文字、全角文字、半角文字を無視して単語を探します。
    例えば「ＴEXTＣLIPpER」と、大文字小文字全角半角が混在している状態で検索しても、「TextClipper」を含むカードや「TEXTCLIPPER」を含むカードが、ツリー部に表示されます。

    2-4.タイトルのみ検索 チェックマークをつけると、2-1.で入力した単語がタイトルに含まれたカードだけが、ツリー部に表示されます。

    2-5.作成日 入力した期間内に作られたカードだけが、ツリー部に表示されます。

    2-6.更新日 入力した期間内に作られたカードだけが、ツリー部に表示されます。

    2-7.カード種類アイコン これを押して、アイコンリストから選択します。該当アイコンのみが検索対象になります。

    2-8.出典 入力した出典のカードだけが、ツリー部に表示されます。
    出典名はかならず「あいまい検索」になります。

    該当カードのみを表示 見つかったカードだけが表示されます。
    この後、元の状態に戻してデータファイルを全部表示させたいときは、「再読込」ボタン [image] を押します。

    現在のフォルダを検索 いまいるフォルダの下のカードを検索の対象にします。検索時間が短縮されるので、カードが多いとき効果的です。

    該当カードにマークを付ける 該当カードのみ表示の場合にもマーク 赤いチェック を付けることができます。フォルダが多いとき「F4」で移動できるので便利です。

  3. ［検索］ボタンを押す。
    検索が始まります。
    検索が終了すると、ツリー部には［検索］ダイアログに入力した条件にあったカードにマークがつきます。
  4. 検索結果の参照。
    カード間移動(F4) と、カード内移動(F3) の両方で移動して参照できます。
    テキスト画面からツリー画面に指定を戻すときは、(F6)をはさんで下さい。

  5. ［検索］メニューから［検索解除］を選ぶ。
    もしくは、「再読込」ボタン [image] を押します。
    すべてのマークをクリアします。
気をつけよう ［検索解除］を選ぶと、［検索］を選んでつけたマーク以外のマークもクリアされます。
[Keyword] 検索メニュー
カード検索
検索解除


［入出力］メニュー(TextClipper)

［入出力］メニュー

他TextClipper取り込み
他TextClipper用書き出し
他TextClipper直接書き出し
カード読み込み
カード書き出し
[Keyword] 入出力メニュー


［入出力］メニュー - 他TextClipper取り込み(TextClipper)

入出力(I)→他TextClipper取り込み

  TextClipperで書き出したデータを、取り込みます。

  複数の人たちで同じカードを共有したり、ダウンロードしたフリーのカード集を、TextClipperで使ったりすることができます。
  カードのバックアップをするときや、TextClipperをバージョンアップするときも使います。

  データファイルを複数のパソコンで同期メンテナンスする場合は、「ファイル」の「完全バックアップ」で書き出して、この「取り込み」をします。
チョットひとこと 　「更新日を比較しないで全て取り込む」にチェックが入っていない状態(デフォルト)で、取り込みすると、他のパソコンで更新した部分だけを取り込んでくれます。
  この機能を使って、複数のパソコンで TextClipper のデータを相互にやり取りすることで、データの共有(シンクロ更新)をすることができます。

  例えば、会社のパソコンのデータと、家庭のパソコンのデータの連係同期をとることができます。

手順

  1. TextClipperのデータファイルを指定フォルダに解凍する。
      「完全バックアップ」などで作成したデータファイル(拡張子はlzh)を、取り込み用のフォルダに解凍します。

      画面の例では、C ドライブの temp フォルダに解凍します。
      すると、そのフォルダに、「totextcp.dat」というファイルができます。拡張子が dat となっていますが、完全なテキストファイルです。
    気をつけよう 　このファイル名からは、データファイルがどれだっか分かりません。複数のデータファイルを使っている場合は、取り込むファイルを間違わないように、注意して下さい。
  2. ［入出力］メニューから［他TextClipper取り込み］を選ぶ。
    ［パス設定］ダイアログが表示されます。

  3. TextClipperで書き出したデータがあるパス（フリーのカード集のあるパス）を半角で入力する。
    C:\TextClipper\Cards\HTML\のように、\マークまで書きます。
    画面の例では、c:\temp\

  4. Enterキーを押す。
      入力したパスでカードが見つかったときは、［成功］メッセージが表示され、カードが増えます。
      入力したパスでカードが見つからなかったときは、［警告］メッセージが表示されます。

      取り込むカードのフォルダと現在のフォルダが違う場合、下の画面が出ます。ここで、新しいフォルダに移動するか、そのまま内容だけを更新するかの指定ができます。

気をつけよう 　「完全バックアップ」のとき、ベース側のデータファイルで、カードをフォルダを移動しただけでは、他のパソコンで「取り込み」したとき、フォルダ移動の情報が取込まれません。
  この場合は、ベース側パソコンでカードのフォルダ移動した後、どこか編集してカードの更新日をアップデートした上で、「完全バックアップ」しておきます。

気をつけよう 　TCは、カードを新しく作るときに、そのカードにユニークなIDを付けます。
  このIDは、Time()とGetTickCount()で、絶対に同じものはありません。

  このIDは、そのカードが削除されるまで有効で、取り込みや書き出しで他のコンピュータに移っても生き続けます。このIDを比較して取り込みの時に更新しています。
  ですから、もしあるカードが不要になったとき、その内容と、タイトルを全く別なものに書き換えるようなことはしないで下さい。 もし、別のコンピュータにその元のカードがあった場合、IDが同じなので同一カードと見なされます。

  例えば、「山本さんの住所」というカードあって、それをノートパソコンから取り込んだとします。
  その住所が不要だからと言って、「田中さんの住所」に変更したとします。
  ノートの方では、「山本さんの住所」を転居先に更新したとして、ノートのデータを再度取り込むと、「田中さんの住所」のデータは無くなって、「山本さんの住所」が転居先の新しい住所で生き返る、と言うことです。これはIDが同じだからです

  不要になったカードは削除して、新規に作るようにして下さい。

チョットひとこと 　特定のカードのデータを間違って更新してしまったり、データを消してしまった場合も、バックアップが有れば復旧することができます。
  このときは、該当のカードを完全削除した後、この「他TextClipper取り込み」をします。
  こうすれば、該当カードだけを復旧できます。

  「更新日を比較しないで全て取り込む」にチェックを入れて取り込みすると、バックアップを作成した後に更新した、全てのカードが、バックアップの時点のものに戻ってしまうので、「更新日を比較しないで全て取り込む」ことは、推奨しません。

気をつけよう 　まれに、新しいバージョンの TextClipper で書き出したファイルを、古いバージョンの TextClipper で取り込めないことがあります。
  こんな場合は、 TextClipper のバージョンを最新に更新して下さい。

[Keyword] 入出力メニュー
他TextClipper取り込み


［入出力］メニュー - 他TextClipper用書き出し(TextClipper)

入出力(I)→他TextClipper用書き出し

  TextClipperのカードを書き出します。書き出したものを取り込むには、他TextClipper取り込みを使います。
  複数の人たちで同じカードを共有したり、ダウンロードしたフリーのカード集を、TextClipperで使ったりすることができます。
  マーク [image] を付けたデータだけを書き出すことができます。
チョットひとこと 　ホームページ(インターネット・エクスプローラ)から一発登録した「画像」は、テキストにエンコードして、カードに埋め込まれます。
  このため、テキストだけのカードと同様に、他のTextClipperと画像を含めて、一つのカードデータとして入出力できます。
  この技は、TC のアドバンテージです。

手順

  1. ツリー部で、書き出したいカードのアイコンをクリックして選ぶ。
    選んだカードにマークがつきます。

  2. ［入出力］メニューから［他TextClipper用書き出し］を選ぶ。
    もしくは、ツリー部のポップアップ(コンテキスト)メニューから［他TextClipper用書き出し］を選ぶ。
    ［パス設定］ダイアログが表示されます。

  3. TextClipperのデータを書き出すパスを半角で入力する。
    C:\TextClipper\Cards\HTML\のように、\マークまで書きます。
    LANでつながっている場合、相手のドライブのフォルダを指定して落とすこともできます。

    入力したパスが見つかったときは、手順1でマークをつけたカードが書き出されます。ファイル名は「totextcp.dat」です。

    入力したパスが見つからなかったときは、［警告］メッセージが表示されます。
    ★「ディスクをチェックしてください。」は恐すぎます。★
チョットひとこと 　すべてのカードを書き出したい場合は、ツリー部の右クリックメニューを使うと、すべてのカードにマークをつけることができます。
マーク関連
気をつけよう 　パスは、すでに存在するパスを指定してください。
  バックアップで作成するファイルと同じ内容ですが、圧縮はされません。
[Keyword] 入出力メニュー
他TextClipper用書き出し


［入出力］メニュー - 他TextClipper直接書き出し(TextClipper)

入出力(I)→他TextClipper直接書き出し

カードを他のデータに直接書き出します。
データ1からデータ2へカードをコピーするときに使います。

手順

  1. ツリー部で、書き出したいカードのアイコンをクリックして選ぶ。
    選んだカードにマーク [image] がつきます。

  2. ［入出力］メニューから［他TextClipper直接書き出し］を選ぶ。
    もしくは、選んだカードを右クリックして表示されるポップアップ(コンテキスト)メニューから［他TextClipper直接書き出し］を選ぶ。
    登録されているデータの一覧が表示されます。

  3. 一覧から、書き出し先のデータを選ぶ。
    手順1でマークをつけたカードが、手順3で選んだデータにコピーされます。
チョットひとこと すべてのカードを書き出したい場合は、ツリー部の右クリックメニューを使うと、すべてのカードにマークをつけることができます。
マーク関連
[Keyword] 入出力メニュー
他TextClipper直接書き出し


［入出力］メニュー - カード読み込み(TextClipper)

入出力(I)→カード読み込み

テキストファイルの内容を読み込んで、カードとして登録します。

手順

  1. ツリー部で、カードを登録するフォルダを選ぶ。
    選んだフォルダが反転表示されます。

  2. ［入出力］メニューから［カード読み込み］を選ぶ。
    もしくは、選んだフォルダを右クリックして表示されるポップアップ(コンテキスト)メニューから［カード読み込み］を選ぶ。
    ［ファイルを開く］ダイアログが表示されます。

  3. ファイルを選んで、［開く］を押す。
    テキストファイルの内容を読み込んで、手順1で選んだフォルダに、カードとして登録します。
チョットひとこと カード読み込み機能では…
  • テキストファイルの1行目をカードのタイトルとして読み込みます。
  • 行頭から半角の@が15個以上続く行（@@@@@@@@@@@@@@@）をカードの区切りとして、テキストファイルを読み込みます。
気をつけよう ［カード書き出し］で書き出したカードを［カード読み込み］で読み込んでも、元の状態に戻すことはできません。
[Keyword] 入出力メニュー
カード読み込み


［入出力］メニュー - カード書き出し(TextClipper)

入出力(I)→カード書き出し

  マーク [image] をつけたカードを書き出します。
  カードを印刷したり、他のソフトや他のパソコンに渡すときなどに使います。
  書き出したファイルは、TClipのプログラムが登録してあるフォルダに保存されます。

手順

  1. ツリー部で、書き出したいカードのアイコンをクリックして選ぶ。
    選んだカードにマークがつきます。

  2. ［入出力］メニューから［カード書き出し］を選ぶ。
    もしくは、選んだカードを右クリックして表示されるポップアップ(コンテキスト)メニューから［カード書き出し］を選ぶ。
    ［書き出しオプション］ダイアログが表示されます。

    • ［全情報］にチェックマークをつけると、カードが所属するグループや、カードのタイトルなど、全部で5種類の情報も同時に書き出されます。
    • ［本文のみ］にチェックマークをつけると、カードの内容だけが書き出されます。
    • ［タイトルと本文］にチェックマークをつけると、カードとカードの内容が、書き出されます。

      更に、書き出し処理のオプションが選択できます。

      • ［1行データをタブ区切りに］
      • ［書き出し後クリップボードに入れる］：ファイルに保存すると同時に、クリップボードにも登録して、他のソフトにすぐ貼り付けできる状態にします。
      • ［カードの区切りに区切り線を入れる］

    • ［階層付き(タイトルと本文)］にチェックマークをつけると、「階層付きテキスト」形式で出力できます。
    チョットひとこと 　「階層付きテキスト」形式とは、ツリーのレベルの階層構成を記号「.(ピリオド)」で表示する、一般的な、ファイルレイアウトです。
      他の「アウトラインプロセッサ・ソフト」にデータを渡すときに活用下さい。
      Palmでも、例えば、フリーソフトの「WDIC」は、「階層付きテキスト」を読めるので、TCのデータをPalmに入れて持ち運べるようになります。

  3. ［書き出し］ボタンを押す。
    手順1でマークをつけたカードが、テキストファイルに書き出されます。
    書き出しが終わると、テキストファイルが表示されます。
チョットひとこと 　ツリー部で、カードにマークを付けないと、すべてのカードを書き出すことができます。
マーク関連
[Keyword] 入出力メニュー
カード書き出し


［環境設定］メニュー(TextClipper)

［環境設定］メニュー

WordWrap
Text部の背景色
ツリー部のフォント(ツリー部にカーソルが有るとき)
テキスト部のフォント(テキスト部にカーソルが有るとき)
環境設定
[Keyword] 環境設定メニュー


［環境設定］メニュー - WordWrap(TextClipper)

環境設定(O)→WordWrap

ワードラップを設定します。
［WordWrap］にチェックマークがついていると、カードの内容がテキスト部に表示されるときに、テキスト部の右にはみ出ないように適当な位置で改行されます。
［WordWrap］のチェックマークが外れていると、カードの内容がそのまま表示されます。

手順

  1. ［環境設定］メニューから［WordWrap］を選ぶ。
    チェックマークがつきます。
    カードの内容がテキスト部に表示されるときに、テキスト部の右にはみ出ないように適当な位置で改行されます。

  2. ［環境設定］メニューから［WordWrap］を選ぶ。
    チェックマークが外れます。
    カードの内容がそのまま表示されます。
[Keyword] 環境設定メニュー
WordWrap
ワードラップ


［環境設定］メニュー - Text部の背景色(TextClipper)

環境設定(O)→Text部の背景色

  テキスト部の背景色を変更できます。

  背景色を変更した場合は、合わせて、「テキスト部のフォント」で、フォントの色を背景色の補色(反対の色)に指定すると、文字が見やすくなります。
  背景色とフォントの色を、補色ではなく、同系色にすると、落ち着いた雰囲気になります。

  背景色は、印刷のときや、テキスト部のデータをクリップボードにコピーしたときは無視されます。
(クリップボードにコピーしたデータは、書式付きのリッチテキストではなく、文字のみのフラットテキストです。)

手順

  1. ［環境設定］メニューから［Text部の背景色］を選ぶ。
    カラーパレットが現れるので、好みの色を選択します。
[Keyword]


［環境設定］メニュー - テキスト部のフォント(TextClipper)

環境設定(O)→テキスト部のフォント

カードの内容を表示するデフォルトのフォントの形・大きさ・色を設定します。

(フォントは、カードごとにテキスト部のコンテキストメニューで変えることができます。)

カードの背景色は、「環境設定(O)」→「Text部の背景色」で設定します。
ツリー部のフォントは、ツリー部のコンテキストメニューで変更できます。

手順

  1. テキスト部にカーソル(コントロール)を置いて、［環境設定(O)］メニューから［テキスト部のフォント］を選ぶ。
    フォントを設定するダイアログが表示されます。
    (この「環境設定(O)」→「フォント」のメニューは、カーソルがツリー部にあるかテキスト部にあるかの違いで、「ツリー部のフォント」と切り替わります。)

  カードの内容を表示するデフォルトのフォントは、テキスト部のコンテキストメニューを使って設定することもできます。

手順

  1. どれかのカードで、読みやすいフォントにしておきます。
  2. そして、テキスト画面の右クリックで表示されるメニューから、「このカードのフォントをデフォルトのフォントとする」を選択します。
[Keyword] 環境設定メニュー
Font
フォント


ツリー部ポップアップ ツリー部のフォント(TextClipper)

環境設定(O)→ツリー部のフォント

ツリー部のフォントを設定します。

テキスト部のフォントは、テキスト部にカーソル(コントロール)を置いて、「環境設定(O)」の「テキスト部のフォント」で変更します。

手順

  1. ツリー部を右クリックして表示されるポップアップ(コンテキスト)メニューから［ツリー部のフォント］を選ぶ。
    もしくは、ツリー部にカーソル(コントロール)を置いて、［環境設定(O)］メニューから［ツリー部のフォント］を選ぶ。
(この「環境設定(O)」→「フォント」のメニューは、カーソルがツリー部にあるかテキスト部にあるかの違いで、「テキスト部のフォント」と切り替わります。)

フォントを設定するダイアログが表示されます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
Font
フォント


［環境設定］メニュー - 環境設定(TextClipper)

環境設定(O)→環境設定

TextClipperの動作を細かく設定します。

手順

  1. ［環境設定］メニューから［環境設定］を選ぶ。
    ［環境設定］ダイアログが表示されます。

関連項目

環境設定ダイアログ
[Keyword] 環境設定メニュー
環境設定


［ヘルプ］メニュー(TextClipper)

［ヘルプ］メニュー

バージョン情報
ヘルプ
[Keyword] ヘルプメニュー


［ヘルプ］メニュー - バージョン情報(TextClipper)

ヘルプ(H)→バージョン情報

TextClipperのバージョンを確認します。
TextClipperについて質問などをするときは、「TextClipper Version x.xx」をメールに書き添えてください。

手順

  1. ［ヘルプ］メニューから［バージョン情報］を選ぶ。
    ［About TextClipper］ダイアログが表示されます。
[Keyword] ヘルプメニュー
バージョン情報


［ヘルプ］メニュー - ヘルプ(TextClipper)

ヘルプ(H)→ヘルプ

TextClipperのヘルプを表示します。

手順

  1. ［ヘルプ］メニューから［ヘルプ］を選ぶ。
    TextClipperのヘルプが表示されます。
[Keyword] ヘルプメニュー
ヘルプ


ツリー部ポップアップ(コンテキスト)メニュー(TextClipper)

ツリー部ポップアップ(コンテキスト)メニュー

トップページ 　ツリーリスト内でマウスの右クリックをするか、[Esc]キーを押すと、メニューが開きます。
そこから処理を選んで下さい。
  よく使うと思われる機能は、上部にボタンとして配置しています。
新規フォルダ
フォルダ名変更
移動
カード読み込み
カード書き出し
他TextClipper取り込み
他TextClipper直接書き出し
他TextClipper用書き出し
カード検索
？？一括置換
再読み込み
複製
削除
削除済みカード
一括属性変更
マーク関連
リスト書式
並び替え
ツリー部のフォント
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー


ツリー部ポップアップ フォルダ名変更(TextClipper)

フォルダ名変更

フォルダの名前を変更します。

手順

  1. ツリー部で、名前を変更したいフォルダを選ぶ。
    フォルダが反転表示されます。

  2. フォルダ名を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［フォルダ名変更］を選ぶ。
    フォルダ名が変更できる編集モードになります。

  4. フォルダ名を入力して、ENTERキーを押す。
    フォルダ名が登録され、編集モードが終了します。
チョットひとこと 　環境設定(O)→環境設定(O)　その他タブで、「カード並び替えを自動で行う」にチェックを入れて、
  ツリー部ポップアップメニューで、「タイトル昇順」としておくと、
  起動時や、データを再読込するたびに、フォルダ名やカードタイトルの文字コード(英字の大文字と小文字は区分されます)の順に、自動で並び替えられます。

  TCをアウトライン・プロセッサとして用いる場合は、章や節の番号を、フォルダ名やカードタイトルの先頭に付けて、この機能を使います。章や節の順番を入れ替えるときは、タイトルの数字を書き換えるだけで良いのです。

  注：フォルダ名は１０文字程度までで、スペースは使えません。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
フォルダ名変更

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 移動(TextClipper)

移動

フォルダやカードを移動します。

カードを移動する手順

  1. 移動したいカードを選ぶ。
    複数選ぶときは、カードにマーク [image] を付けます。
    マーク関連

  2. 選んだカードを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［移動］を選ぶ。
    カードのアイコンが、指アイコンに変わります。

  4. 移動先のフォルダをクリックする。
    カードが移動されます。
    カーソルキーでも移動させられます。
チョットひとこと 　カードやフォルダを別のフォルダへ移動するには、移動したいカードやフォルダを左クリックして、ドラッグしても移動できます。
  しかし、移動先が遠く離れたフォルダの場合は、このポップアップ(コンテキスト)メニューの［移動］の方が、簡単で確実です。
  ドラッグ＆ドロップでは、一番下には移動できないため、下から2番目に移動して一番下のカードを1つ上に移動することで対応して下さい。
気をつけよう カードの移動では…
  • Rootフォルダに、カードを移動することはできません。
  • カードをクリックしたときは、カードのすぐ上に移動されます。

フォルダを移動する手順

  1. 移動したいフォルダを選ぶ。

  2. 選んだフォルダを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［移動］を選ぶ。
    フォルダのアイコンが、指アイコンに変わります。

  4. 移動先のフォルダをクリックする。
    フォルダが移動されます。
気をつけよう 　階層は一応、10ほどまでです。それ以上になったときは動作の保証はできません。
  フォルダの下にフォルダを異動すると、フォルダの階層は足し算で深くなるので、注意して下さい。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
移動

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 他TextClipper取り込み(TextClipper)

他TextClipper取り込み

TextClipperで書き出したデータを取り込みます。
複数の人たちで同じカードを共有したり、ダウンロードしたフリーのカード集を、TextClipperで使ったりすることができます。
カードのバックアップをするときや、TextClipperをバージョンアップするときも使います。

手順

  1. ツリー部で、カードを登録するフォルダを選ぶ。
    選んだフォルダが反転表示されます。

  2. 選んだフォルダを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［他TextClipper取り込み］を選ぶ。
    ［パス設定］ダイアログが表示されます。

  4. TextClipperで書き出したデータがあるパス（フリーのカード集のあるパス）を半角で入力する。

    C:\TextClipper\Cards\HTML\のように、\マークまで書きます。
    入力したパスでカードが見つかったときは、メッセージが表示され、カードが増えます。

    入力したパスでカードが見つからなかったときは、［警告］メッセージが表示されます。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
他TextClipper取り込み

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 一括置換(TextClipper)

一括置換

マニュアル未作成です。　m(__)m

手順

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 再読み込み(TextClipper)

再読み込み

いま開いているデータを読み込み直します。

手順

  ツリー部の上段の、「再読込」のボタン [image] を押すか、または、下記のようにします。
  1. ツリー部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［再読み込み］を選ぶ。
      データが読み込み直されます。

    1. カード検索していたときは、元の全件表示の状態に戻します。
    2. マーク [image] はクリアします。
    3. 「環境設定(O)」→「環境設定(O)」のその他タブで、「起動時にツリーを展開させる」にチェックが入っていない場合は、ツリーを全て閉じます。
    4. カードの追加や編集をした場合は、ツリー部ポップアップメニューで指定した順序に自動で並び替えます。

      つまり、一気に上の a～d をしたいときに「再読込」を使います。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
再読み込み

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 複製(TextClipper)

複製

選択したカードと同じ内容のカードを作ります。

手順

  1. ツリー部で、書き出したいカードを選ぶ。
    選んだカードが反転表示されます。

  2. 選んだカードを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［複製］を選ぶ。
    手順1で選択したカードと同じ内容のカードが作られます。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
複製

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 削除(TextClipper)

削除

  ツリー部から、フォルダや、カードをTCの「ごみ箱」に移動します。
  フォルダを削除する場合は、フォルダに含まれるカードも移動されます。

  TCのごみ箱から復活させたり、完全に削除するには、「編集」→「削除澄みカード」で処理します。

カードを削除する手順

  1. ツリー部で、削除したいカードのアイコンをクリックして選ぶ。
    選んだカードにマーク [image] がつきます。

  2. 選んだカードを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［削除］を選ぶ。
    ［注意］ダイアログが表示されます。

  4. ダイアログに表示されたメッセージの通りに削除していい場合は、［はい］ボタンを押す。
    カードが削除されます。

フォルダを削除する手順

  1. ツリー部で、削除したいフォルダを選ぶ。
    フォルダが反転表示されます。

  2. 選んだフォルダを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［削除］を選ぶ。
    ［注意］ダイアログが表示されます。

  4. ダイアログに表示されたメッセージの通りに削除していい場合は、［はい］ボタンを押す。
    再度［注意］ダイアログが表示されます。

  5. ダイアログに表示されたメッセージの通りに削除していい場合は、［はい］ボタンを押す。
    フォルダと、フォルダに含まれるカードが削除されます。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
削除

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 一括属性変更(TextClipper)

一括属性変更

カードの出典名、アイコン、一発ペースト用チェックマークの３つを複数のカードに対して、一括して設定することができます。

手順

  1. ツリー部で、属性を変更したいカードのアイコンをクリックして選ぶ。
    選んだカードにマーク [image] がつきます。

  2. 選んだカードを右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［一括属性変更］を選ぶ。
    ［一括属性変更］ダイアログが表示されます。

  4. 属性を設定する。
    ［クリア］ボタンを押すと、選択を解除できます。設定を変更したくない場合は、空欄のままにしておきます。
    4-1.出典名 出典名タブ

    4-2.カード種類アイコン カードアイコンタブ

    4-3.Paste 一発ペースト用に設定します。
    一発ペースト機能

  5. ［登録］ボタンを押す。
    属性が設定され、［一括属性変更］ダイアログが閉じます。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
一括属性変更

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ マーク関連(TextClipper)

マーク関連

  マークとは、ツリー部のカードアイコンに付く、赤いチェック 赤いチェック のことです。

  ツリー部で、カードにマークする方法は、
  • カードのアイコンを、マウスで左シングルクリックします。
  • または、スペースキーを押します。
  (ツリーでタイトルをマウス左クリックすると、テキスト部に該当カードが表示されますが、アイコンには赤いマークが付きません。
  マウス左でダブルクリックすると、さらに、簡易エディタが開きます。)

  下記の操作で、一括でマークをつけたり、一括でマークを外したりすることができます。

手順

  1. ツリー部で右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［マーク関連］を選ぶ。
    マークのつけかた／はずしかたの一覧が表示されます。
    項目 | 意味
    マーク全セット | すべてのカードにマークをつけます。
    このフォルダのデータをマーク | 選択したファルダに含まれるカードにマークをつけます。
    このフォルダの下のデータをマーク 選択したフォルダに含まれるカードにマークをつけます。 さらに、選択したフォルダに含まれるフォルダの中にあるカードにもマークをつけます。
    マーク全クリア | すべてのカードのマークをはずします。
    このフォルダのデータのマークをクリア | 選択したファルダに含まれるカードのマークをはずします。
    このフォルダの下のデータのマークをクリア 選択したフォルダに含まれるカードのマークをはずします。 さらに、選択したフォルダに含まれるフォルダの中にあるカードのマークもはずします。
    マークされていないデータをリストからはずす マークされているカードだけを、ツリー部に表示します。 検索解除すると、すべてのカードをツリー部に表示することができます。
    カード検索・検索解除
    一発ペーストするデータにマーク | ［ペースト］にチェックマークがついているカードにマークをつけます。
    一発ペーストしないものにマーク | ［ペースト］にチェックマークがついていないカードにマークをつけます。
    マークの反転 | マークがついているカードは、マークをはずします。逆に、マークがはずれているカードは、マークをつけます。

  3. 一覧から項目を選ぶ。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
マーク関連

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ リスト書式(TextClipper)

リスト書式

ツリー部でのカードの表示形式を変えることができます。

手順

  1. ツリー部で右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［リスト書式］を選ぶ。
    選択できる表示形式の一覧が表示されます。
    項目 | 意味
    タイトルのみ | タイトルだけを表示します。
    作成日＋タイトル | 作成日とタイトルの2つを表示します。
    更新日＋タイトル | 更新日とタイトルの2つを表示します。
    作成日＋更新日＋タイトル | 作成日、更新日、タイトルの全てを表示します。

  3. 一覧から項目を選ぶ。
チョットひとこと 作成日はカードを作った日、更新日はカードを修正した日のことです。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
リスト書式

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


ツリー部ポップアップ 並び替え(TextClipper)

並び替え

ツリー部で、カードの並び順を変えることができます。

手順

  1. ツリー部で右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［並び替え］を選ぶ。
    選択できる並び替え方法の一覧が表示されます。
    項目 意味
    タイトル昇順
    タイトル降順     		タイトルを基準に、カードを並び替えます。
    登録日昇順
    登録日降順     		作成日を基準に、カードを並び替えます。
    更新日昇順
    更新日降順     		更新日を基準に、カードを並び替えます。
      環境設定ダイアログ - その他タブで、「カード並び替えを自動で行う」にチェックを入れると、データを再読込すると、上で指定した順序に自動で並び変えられます。

  3. 一覧から項目を選ぶ。
チョットひとこと 作成日（登録日）はカードを作った日、更新日はカードを修正した日のことです。
気をつけよう フォルダを選んでいるときは、このメニューを選んでも何も起こりません。
[Keyword] ツリー部ポップアップ(コンテキスト)メニュー
並び替え

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ(コンテキスト)メニュー(TextClipper)

テキスト部ポップアップ(コンテキスト)メニュー

登録
元に戻す
コピー
切り取り
貼り付け
全選択
全コピー
印刷
検索
置換
カード分割
タイトルセット
WordWrap
このカードのフォントを変える
このカードのフォントをデフォルトのフォントとする
(デフォルトのフォントを、表示中のカードのフォントに変更します。)
このカードのフォントをデフォルトのフォントに戻す
(表示中のカードの表示を、デフォルトのフォントを使った表示に戻します。)
クリップツール
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー


テキスト部ポップアップ 登録(TextClipper)

登録

カードを登録します。

チョットひとこと ［登録］を選ばなくても、他のカードを表示したり、ツリー部をクリックしたりすれば、カードは登録されます。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［登録］を選ぶ。
    カードが登録され、テキスト部の上にある［登録］ボタンが押せなくなります。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
登録

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ 切り取り(TextClipper)

切り取り

  テキスト部で反転表示されているテキストを、クリップボードにコピーして、テキスト部からは削除します。

手順

  1. テキスト部で、切り取りたいテキストを選ぶ。
    選んだテキストが反転表示されます。
    SHIFTキーを押しながら、カーソルキーで選ぶことができます。
    マウスをドラッグして選ぶこともできます。

  2. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［切り取り］を選ぶ。
    手順1で選んだテキストが、クリップボードにコピーされ、テキスト部から削除されます。

参考

  クリップボードにコピーしたテキストの、貼り付け方法。


テキスト部ポップアップ 全選択(TextClipper)

全選択

テキスト部のすべてのテキストを選びます。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

    • ポップアップ(コンテキスト)メニューから［全選択］を選ぶ。
        もしくは、
    • 左手小指で、[Ctrl]を押しながら、左手の他の指で[A]を押して、左手を上げる。(←最も簡単にできるので、この方法を推奨します。)

    テキスト部に表示されているすべてのテキストが選ばれます。


テキスト部ポップアップ 全コピー(TextClipper)

全コピー

テキスト部のすべてのテキストを、クリップボードにコピーします。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［全コピー］を選ぶ。
    テキスト部に表示されているすべてのテキストが、クリップボードにコピーされます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
全コピー

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ 検索(TextClipper)

検索

テキスト部から、単語を探します。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［検索］を選ぶ。
    検索文字列設定ダイアログが表示されます。

  3. ［検索文字列］入力欄に、テキスト部から探したい単語を入力する。

  4. ［OK］ボタンを押す。
    検索が始まります。
    単語が見つかったときは、見つかった単語が反転表示されます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
検索

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ 置換(TextClipper)

置換

テキスト部の単語を、別の単語に置き換えます。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［置換］を選ぶ。
    ［置換］ダイアログが表示されます。

  3. ［検索文字列］入力欄に、置き換える前の単語を入力する。

  4. ［置換文字列］入力欄に、置き換えた後の単語を入力する。

  5. （必要なら）［大文字小文字を区別］にチェックマークをつける。
    チェックマークをつけると、大文字と小文字を別の文字と見なします。
    チェックマークをつけないと、大文字と小文字を同じ文字と見なします。

  6. ［OK］ボタンを押す。
    置換が始まります。
    ［検索文字列］入力欄に入力した単語が見つかったときは、その単語が反転表示され、［確認］ダイアログが表示されます。

    ［検索文字列］入力欄に入力した単語が見つからなかったときは、エラー音が鳴って、置換は終了します。

  7. いずれかのボタンを押す。
    ［置換］ボタンを押すと、反転表示されている単語を、［置換文字列］入力欄に入力した単語に置き換えます。
    ［次検索］ボタンを押すと、反転表示されている単語は、置き換えません。もう一度［検索文字列］入力欄に入力した単語を検索します。
    ［全置換］ボタンを押すと、すべての［検索文字列］を［置換文字列］に置き換えます。
    ［Cancel］ボタンを押すと、置換処理を終了します。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
置換

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ カード分割(TextClipper)

カード分割

テキスト部のカーソル位置より後ろのテキストを、新しいカードにします。

手順

  1. テキスト部で、カードを分割したい場所にカーソルを動かす。
    カーソルキーで動かすことができます。
    マウスでクリックして、カーソルを動かすこともできます。

  2. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［カード分割］を選ぶ。
    カーソル位置から後ろのテキストが新しいカードになります。
チョットひとこと 新しいカードのタイトル、出典名などは、現在のカードと同じになります。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
カード分割

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ タイトルセット(TextClipper)

タイトルセット

  テキスト部で反転表示されているテキストを、カードのタイトルとして登録します。
  タイトルセットの時、テキストを選択していない場合は、最初の部分をタイトルとして取得します。

手順

  1. テキスト部で、カードのタイトルとして登録したいテキストを選ぶ。
    選んだテキストが反転表示されます。
    SHIFTキーを押しながら、カーソルキーで選ぶことができます。
    マウスをドラッグして選ぶこともできます。

  2. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  3. ポップアップ(コンテキスト)メニューから［タイトルセット］を選ぶ。
    手順1で選んだテキストが、カードのタイトルとして登録されます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
タイトルセット

Copyright © 2004-2007 YOSHIMURA Takaki. All rights reserved.


テキスト部ポップアップ WordWrap(TextClipper)

WordWrap

ワードラップを設定します。
［WordWrap］にチェックマークがついていると、カードの内容がテキスト部に表示されるときに、テキスト部の右にはみ出ないように適当な位置で改行されます。
［WordWrap］のチェックマークが外れていると、カードの内容がそのまま表示されます。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［WordWrap］を選ぶ。
    チェックマークがつきます。
    カードの内容がテキスト部に表示されるときに、テキスト部の右にはみ出ないように適当な位置で改行されます。

  3. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  4. ポップアップ(コンテキスト)メニューから［WordWrap］を選ぶ。
    チェックマークが外れます。
    カードの内容がそのまま表示されます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
WordWrap
ワードラップ


テキスト部ポップアップ このカードのフォントを変える(TextClipper)

このカードのフォントを変える

  カードの内容を表示するフォントを設定します。

  カードのデフォルトのフォントは、環境設定のテキスト部のフォントでも設定できます。
  ツリー部のフォントは、ツリー部のコンテキストメニューで変更できます。

手順

  1. テキスト部を右クリックする。
    ポップアップ(コンテキスト)メニューが表示されます。

  2. ポップアップ(コンテキスト)メニューから［このカードのフォントを変える］を選ぶ。
    フォントを設定するダイアログが表示されます。
[Keyword] テキスト部ポップアップ(コンテキスト)メニュー
Font
フォント


使い方(TextClipper)

使い方

はじめに

初級編

  実行方法
  梱包ファイルを解凍してTEXTCLIP.EXEをダブルクリック！

  カードの登録と画面
  フォルダを指定してエディタ部分に書き込むだけ。
  カード中の文章で、検索と置換ができます。

  一発フロッピー書き出し
  自分で書いたテキストを人に渡す時、フロッピーに落とすのも結構面倒なものです。
  ここに登録してあるテキストならそのカードを表示させて「フロッピーボタン」を押すだけでそのカードのテキストをフロッピーに書き出すことが可能です。
  初心者の方のエディタとしても利用できるでしょう。
  表モードのものはCSVファイルとして書き出します。

  一発ペースト　超一発ペースト
  コンパクトなボタンウインドウを使って、普段使っているエディタなど他のソフトに、テキストを簡単に張り付けられます。ボタンウインドウを使わずに、キー操作でもできます。
  クリップボードの履歴もペーストできます。

  一発登録
  ここを登録したいというところをマウスで選択してボタン一発で登録されます。

  ブラウザ(インターネット・エクスプローラ)から一発登録でカードに追加すると、テキスト・データだけでなく、画像や表も同時に取り込むことができます。
(バージョン7.8 ～で追加された機能です。
スタイルシートCSSで指定した、色やフォントは、再現できません。)

  カードの削除

  ツリーリストでの操作

上級編

  カード検索
  指定した文字を含むカードを検索します。

  置換機能
  定型文書で氏名など一部を変えたいときに便利です。
  プログラミングにも使えます。

  カード読み込み

  環境設定

  カード取り込み 書き出し
  他のコンピュータと TextClipper(以下TCと書きます) のデータを授受したり、他のソフトとデータの受け渡しができます。

  バックアップ
  一発で２種類のバックアップが可能です。

  その他

超上級編

  データファイル切り替え
  データが多くなってきた場合、複数のデータファイルに分けて使えます。

  クリップツール
  クリップボードでテキストの加工を行います。

  クリップツールの作成
  ソース付きなので自分で作って下さい。

トラブル解消法

  FAQのページも参照下さい。
  1. 　ツリーでタイトルをクリックすると、小窓(簡易エディタ)が開いてしまう
      タイトルをマウス左でシングルクリックして下さい。左ダブルクリックだと、簡易エディタが開きます。

  2. 　TCの画面が表示されない
    1. 　突然TCの画面がウインドウから居なくなった(表示されない)ときは、タスクトレイ(タスクバーの通知領域)のアイコンをマウス「左」シングルクリックして現れる、「メニュー(M)」の下の「位置リセット(E)」を実行してみて下さい。
      緑で囲んだ部分が、タスクトレイアイコン

    2. 　上記でもダメで、ボタン・ウインドウ ボタン・ウインドウ だけがパソコンの画面に表示されている場合は、次の方法で、レジストリの情報をリセットします。
      ①SHIFTキーを押しながらTextClipper.exeをクリックして立ち上げる。
      ②「環境設定の情報をクリアしますか？」→　はい
      そして、再度TextClipperを起動します。
      この方法では、環境設定に登録した内容の一部が消えるため、先に a. の方法を試して下さい。

    3. 　テキスト部の背景色を黒にしているとき、リッチテキストを取り込むと、TCのテキスト画面が真っ黒で文字が見えないことが有ります。こんなときは、TCを再起動して下さい。

  3. 　ボタン・ウインドウ ボタン・ウインドウ が、他のソフトのウインドウの裏に隠れて見えなくなる
      「ボタンウィンドウをタイトルバーにのせる」設定にしていないとき、Windowsのバージョンや、他のソフトとの相性で、ボタンウインドウが隠れる場合が有ります。
      この場合は、「環境設定(O)」→「環境設定(O)」→「起動時タブ」で、「ボタンウィンドウをタイトルバーにのせる」にチェックを入れます。

  4. 　他に、Windows のクリップボードのデータを取得するソフト(例えば電子辞書検索ソフト DDwin のクリップボード経由自動検索など)が動いていると、一発登録やクリップツールが働かないことが有ります。
      クリップボードのデータを intercept されないような状態にして使って下さい。

  5. 　ツリー部の幅を変えたいときに、テキスト部との境目にマウスカーソルを持っていっても、ポインターの形が、←||→ に変わらない
      パソコンを再起動して、TCだけを立ち上げて、何も入力していていない状態で試して下さい。他のソフトが動いていたりすると、←||→ が出ない場合が有ります。

  旧バージョンからのコンバート
  次回からのために読んでおいて下さい。

おたより

E-Mail 　:takaki@try-net.or.jp

HomePage :「まなつのみかん」
          http://takaki.la.coocan.jp/
      〒859-62
      北松浦郡鹿町町下歌ヶ浦免957-7
      吉村隆樹
[Keyword] 使い方